open message from Search Messages results does not work well

VERIFIED FIXED in Thunderbird 3.0b3

Status

defect
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: wsmwk, Assigned: rain1)

Tracking

(Blocks 1 bug, {regression})

Trunk
Thunderbird 3.0b3
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

open message from Search Messages results is odd. 

1. create search that hits on messages in a variety of folders (eg trash and inbox) and message state (read and unread)
2. attempt to open messages via double click or Open

a) worst case is message doesn't open - SA message window outline appears briefly then immediately disappears. so far I can only reproduce this for a message in trash folder
b) i could swear in my initial attempt to open an unread message, that the message status did not change to read. but I was not able to reproduce

nothing in error console
> a) worst case is message doesn't open - SA message window outline appears
> briefly then immediately disappears. so far I can only reproduce this for a
> message in trash folder

did a larger test. consistently can't open messages in trash folder from Search Messages
Bug 467768 will either fix this or make it much easier to fix.
Depends on: 467768
Yeah, the db view wrapper seems to be acting up. Taking this.
Assignee: nobody → sid.bugzilla
Status: NEW → ASSIGNED
OS: Windows Vista → All
Hardware: x86 → All
Duplicate of this bug: 500986
Not just trash folder for me.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090628 Lightning/1.0pre Shredder/3.0b3pre ID:20090628031440

I have search results that include 2 different inboxs, rss feeds.
None of which can be opened in a new tab or a new window.
(patch applies over the one from bug 467768)

The main problem is that we don't have any _underlyingFolders, so we do a null dereference there. I'd write a Mozmill test for this, but I'm not sure if it's possible to write one currently. Feel free to r- if it is.

I've also fixed a problem with opening search results in an existing window and the annoying double URL load.
Attachment #385649 - Flags: review?(bugmail)
Ew -- just noticed the trailing whitespace -- fixed locally.
Attachment #385649 - Flags: review?(bugmail) → review+
Comment on attachment 385649 [details] [diff] [review]
[checked in] patch to fix opening messages from a gloda search tab

Please land this now and we'll worry about the unit tests after... the breakage on this is bad enough that we do not want this in a(nother) nightly.
Also, don't mark this bug fixed, as Wayne's problem was actually opening things from the search window (control-shift-f), which is actually broken in a slightly different way from bug 467768. (tabmail is referenced in a window where there is no tabmail.)
Gloda search tab fix pushed to c-c: http://hg.mozilla.org/comm-central/rev/4ad01247f686
Attachment #385649 - Attachment description: possible patch → [checked in] patch to fix opening messages from a gloda search tab
Hm, I had to rework a lot of the helper code to support selection in the search window. :/
Attachment #386097 - Flags: review?(bugmail)
Comment on attachment 386097 [details] [diff] [review]
[checked in] patch to fix opening messages from a search window

You are to be commended for your dedication to and thoroughness in unit
testing.


on file: mail/base/modules/MailUtils.js line 141
>    * @param aViewWrapperToClone [optional] a view wrapper to clone. If null or
>    *                            not given, the message header's folder's
>    *                            default view will be used
>    * @param aTabmail [optional] a tabmail element to use in case we need to

It turns out the syntax for optional things is like so:

@param [aViewWrapperToClone] blah blah blah

See:
http://code.google.com/p/jsdoc-toolkit/wiki/TagParam

Please update all instances of use of [optional] within this patch.
Attachment #386097 - Flags: review?(bugmail) → review+
Comment on attachment 386097 [details] [diff] [review]
[checked in] patch to fix opening messages from a search window

Pushed to c-c, with [optional] fixed: http://hg.mozilla.org/comm-central/rev/4e87cc8301ee

I think this should be fixed now.
Attachment #386097 - Attachment description: patch to fix opening messages from a search window → [checked in] patch to fix opening messages from a search window
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b3
Flags: in-testsuite+
Duplicate of this bug: 501790
v.fixed
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090702 Shredder/3.0b3pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.