Closed Bug 593723 Opened 11 years ago Closed 11 years ago

cannot open more than 9 messages at a time in Thunderbird 3.1.2

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
normal

Tracking

(blocking-thunderbird3.1 .5+, thunderbird3.1 .5-fixed, thunderbird3.0 .9-fixed)

VERIFIED FIXED
Thunderbird 3.3a1
Tracking Status
blocking-thunderbird3.1 --- .5+
thunderbird3.1 --- .5-fixed
thunderbird3.0 --- .9-fixed

People

(Reporter: liana, Assigned: rain1)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.7) Gecko/20100723 Fedora/3.6.7-1.fc13 Firefox/3.6.7
Build Identifier: 3.1.2

Description of problem: It used to be that I could highlight a number of
messages in a folder and open them all at the same time; if it was more than a
certain number (10-20, I don't really know which), I'd get a warning saying
"opening multiple messages may take time, do you want to continue?" and if I
said "yes" it would continue.  I tried this today in TB 3.0.3, and found that
if I have more than 9 messages highlighted, nothing happens when I try to open
them -- no error message, no opened emails.


Reproducible: Always

Steps to Reproduce:
1. Select more than 10 messages
2. Hit "enter".
3.

Actual Results:  
Nothing.

Expected Results:  
Either all of the highlighted messages should open, or an
error message saying that this many messages cannot be opened at one time
should appear.


This bug has been previously reported on fedora's bugzill: https://bugzilla.redhat.com/show_bug.cgi?id=574521
Confirming with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b6pre) Gecko/20100907 Thunderbird/3.2a1pre

Error console contains :

Error: An error occurred executing the cmd_openMessage command: TypeError: bundle.getString is not a function
Source File: chrome://global/content/globalOverlay.js
Line: 75

My settings do open new mails in a windows. Liana what are your settings ?
Status: UNCONFIRMED → NEW
blocking-thunderbird3.1: --- → ?
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
What settings do you want?  I will provide them when I get home this evening.
This is the code that is in error:

http://hg.mozilla.org/comm-central/annotate/c8b0e716441e/mail/base/modules/MailUtils.js#l286

The functions calls are assuming we've got a bundle by document.getElementById("bundle"), whereas we're actually getting it via an xpcom interface.

Looks like a regression from bug 500657.
Blocks: 500657
blocking-thunderbird3.1: ? → .4+
Doh. I only learned very recently that the getElementById and XPCOM bundle interfaces are different.

I'll take this.
Assignee: nobody → sid.bugzilla
Status: NEW → ASSIGNED
Attached patch patchSplinter Review
This can't be tested with our current window-helpers infrastructure because it doesn't support waiting for multiple windows at a time. I spent a little time working out a design for a rewrite of the window-helpers window watcher, but Standard8 and I both decided it's not really worth it just for this one bug.
Attachment #473063 - Flags: review?(bienvenu)
Attachment #473063 - Flags: review?(bienvenu) → review+
http://hg.mozilla.org/comm-central/rev/00284b12b02e
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
blocking-thunderbird3.1: .4+ → .5+
The problem's also on 1.9.1 -- do we need to land this there, too?
blocking-thunderbird3.0: --- → ?
Attachment #473063 - Flags: approval-thunderbird3.0.9?
Comment on attachment 473063 [details] [diff] [review]
patch

I see no harm in landing for 3.0.x as well.
Attachment #473063 - Flags: approval-thunderbird3.0.9? → approval-thunderbird3.0.9+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.11) Gecko/20101004 Thunderbird/3.1.5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.