Closed Bug 500687 Opened 12 years ago Closed 12 years ago

reply-all key binding shouldn't be disabled, even in 1-1 messages

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: davida, Assigned: bwinton)

References

Details

Attachments

(1 file, 1 obsolete file)

ctrl-shift-r is mapped to reply-all, so it's what I've trained my fingers to do to avoid the problem of replying to one when i meant to reply to all.

w/ the latest nightlies, reply-all is disabled if it's a message addressed just to me.

I suspect we want to somehow enable the menu item and the keyboard shortcut, even if we don't want the items in the new popup.
Flags: blocking-thunderbird3?
bug 500229 will likely help mitigate this, however this is still a bug.
Summary: reply-all shouldn't be disabled even in 1-1 messages → reply-all key binding shouldn't be disabled, even in 1-1 messages
Assignee: nobody → bwinton
Sigh.  After all the work I went to to disable those commands...
Status: NEW → ASSIGNED
I don't know if we want the button to be active when the command is active.

If we do, how is this different from just always having Reply-All, even when it does nothing?  And should we just always add Reply-All to the reply button (a la News messages)?

If we don't, will we get a lot of confused users asking why the button is disabled, but the menu option is enabled?

Thanks,
Blake.
Attachment #385908 - Flags: review?(mkmelin+mozilla)
I think we should leave it enabled at all times - some of us almost never use Reply, always use Reply-all, so its confusing to have the button be disabled jsut because there was only one recipient.   I am still replying to ALL the recipients, there just happens to be only one of them.

The keyboard disabling is most annoying since like David I just automatically hit command-shift-R (on a mac) and have to take another action when it doesn't do anything.
Comment on attachment 385908 [details] [diff] [review]
Make the cmd_replyall track the cmd_reply.

Yeah I think the reply-all button should also be enabled all the time. 

I don't think there's need to mention the bug # in the code. Just mention it's the special case where reply-all happens to be just one person.
Duplicate of this bug: 500485
> Just mention it's the special case where reply-all happens to be just one person.

Since the command and button are now doing the same thing, I just removed the comment, because it isn't really a special case anymore.

Thanks,
Blake.
Attachment #385908 - Attachment is obsolete: true
Attachment #386504 - Flags: review?(mkmelin+mozilla)
Attachment #385908 - Flags: review?(mkmelin+mozilla)
Attachment #386504 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 386504 [details] [diff] [review]
Enable the toolbar buttons as well.

Looks good to me! r=mkmelin
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Keywords: checkin-needed
Target Milestone: --- → Thunderbird 3.0b3
Checked in: http://hg.mozilla.org/comm-central/rev/42f0ff4958e0
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.