Closed Bug 501366 Opened 13 years ago Closed 13 years ago

Headers that are too long for a window appear truncated when, in fact, they can be scrolled horizontally

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
All
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 489609

People

(Reporter: Saul.Tannenbaum, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090626 Lightning/1.0pre Shredder/3.0b3pre

When viewing all headers, a header that is too long for the window appears truncated. However, if one clicks on the header and drags it, the header scrolls horizontally and one can see the remaining text.

This is a really cool and clever feature. Since there's no visual indication that the header will scroll, the feature is unfortunately hidden and most will just think that Thunderbird is truncating headers and that you need to "View Source" to see the entire text of a long header.

Reproducible: Always

Steps to Reproduce:
1.Set View -> Headers -> All
2.Select Message with headers too long to fit in the message window
3.
Actual Results:  
The long header looks truncated.

Expected Results:  
Some indication that the  header can be horizontally scrolled to see the additional text should be presented.
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 9942
Status: RESOLVED → VERIFIED
bug 464309 should better dupe since it's a TB bug
Duplicate of bug: 464309
[I've unmarked this as a duplicate, tried to make the description, well, more
descriptive. And, I've attached a screen capture annotated to point out what
I'm trying to describe)

When viewing all headers, a header that is too long for the window appears
truncated. However, if one clicks on the header and drags it, the header
scrolls horizontally and one can see the remaining text.

This is a really cool and clever feature. Since there's no visual indication
that the header will scroll, the feature is unfortunately hidden and most will
just think that Thunderbird is truncating headers and that you need to "View
Source" to see the entire text of a long header.

Reproducible: Always

Steps to Reproduce:
1.Set View -> Headers -> All
2.Select Message with headers too wide to fit in the message window
3.
Actual Results:  
The long header looks as if its been truncated. However, clicking and
dragging near the point of truncation scrolls the contents of this individual
header line.

Expected Results:  
Some indication that the  header can be horizontally scrolled to see the
additional text should be presented.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #4)
> Some indication that the  header can be horizontally scrolled to see the
> additional text should be presented.

same hint in Normal Header mode would be nice.
FWIW, irrc the drag and select-to-the-end capability is there to allow for copy of the text

I didn't find a duplicate for this (which is surprising, OTOH I don't remember ever seeing such a bug) but you are welcome to search through https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=anywordssubstr&short_desc=subject+header&long_desc_type=anywordssubstr&long_desc=display+scroll&product=MailNews+Core&product=Thunderbird&resolution=---&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&chfieldto=Now&field0-0-0=longdesc&type0-0-0=anywordssubstr&value0-0-0=long+wide+characters&field1-0-0=short_desc&type1-0-0=nowordssubstr&value1-0-0=char+thread+news+exten+date+list+mime+tab+decod+encod+sort+context+filter+focus+edit
Severity: normal → minor
OS: Mac OS X → All
Bug 489609 (wrap subject) would solve the majority of this problem. I'll be working on that bug more this year (there's a patch, but it causes other regressions).
The same solution could then be applied to Received: headers and other plain text headers (I've already looked into that). That would solve this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: subjectwrap
You need to log in before you can comment on or make changes to this bug.