If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

window.sidebar undefined; JavaScript returning bad

VERIFIED FIXED

Status

SeaMonkey
Sidebar
P1
major
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Millennium, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m18) Gecko/20000823
BuildID:    2000082313

In JavaScript functions, the "window.sidebar" object is undefined.
As a side effect, it is not possible to add sidebar panels or search engines.

Reproducible: Always
Steps to Reproduce:
1) Go to http://www.rit.edu/~rbg6038/sidebar-test.html

Actual Results:  The page renders as...

The sidebar type is:  undefined
The addPanel type is:
The addSearchEngine type is:

...and errors appear in the JavaScript Console

Expected Results:  The page renders as:


The sidebar type is: object
The addPanel type is: function
The addSearchEngine type is: function

...and no errors appear

Here's the text of the first error that shows up in the console after loading
the page in question (or at least as much as I can fit onto a 1024x768 screen;
the console doesn't want to give me a scrollbar):

Error: [Exception... "Component returned failure code:
0x80004003(NS_ERROR_INVALID_POINTER)[nsIRDFService.GetDataSource]" nsResult:
0x80004003(NS_ERROR_INVALID_POINTER)"location:
Source File: C:\PROGRAM FILES\MOZILLA\SEAMONKEY\components\nsSidebar.js
Line: 65
Column: 0

This appears once for each of the three function calls on the page. The last two
also generate the error: "window.sidebar has no properties" with the source file
being the HTML page.

Comment 1

17 years ago
confirming 082308, winME
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: window.sidebar undefined; JavaScript returning bad → window.sidebar undefined; JavaScript returning bad

Comment 2

17 years ago
*** Bug 50196 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Browser, not engine. Reassigning to DOM Level 0 for further triage -
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
Nominating for beta3 and reassigning to the sidebar component owner, I see no
problems in the DOM code, the problem seems to be in the sidebar component, I
get assertions in RDFServiceImpl::GetDataSource()...
Assignee: jst → slamm
Component: DOM Level 0 → Sidebar
Keywords: correctness, nsbeta3
OS: Windows 95 → All
Priority: P3 → P1
QA Contact: desale → shrir
Hardware: PC → All

Comment 5

17 years ago
Voted and CC'd myself.
This is a major bug and should be fixed asap i have a hunch that this bug is
directly releated to the switch to JAR's

Comment 6

17 years ago
I agree, this is a major bug. I believe it occured before the switch to Jars 
though. And, it's marked as on all platforms, and jars are only enabled in win32 
so far.

Comment 7

17 years ago
nav triage team: [nsbeta3+]

claudius: Isn't this a dupe? This regressed a couple of weeks ago, maybe it's 
filed in one of the JS components?
Whiteboard: [nsbeta3+]

Comment 8

17 years ago
*** Bug 50581 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
From ICP Marketing:

We need the Add Button to work for sidebar evangelism programs which are about
to start in DE, FR, JA

Comment 10

17 years ago
Added myself to the CC line.
(Assignee)

Comment 11

17 years ago
I checked in a fix today. One side note, it seems like the sidebar.addPanel(...) 
function requires all three arguments now (title, content_url, customize_url).
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
(Naive question)
This is a new requirement, yes?

If the tab does not have a customization URL, how should the third argument be 
coded?  This will affect the Sidebar Dev Guide.

Comment 13

17 years ago
I hope a null value for "customize_url" is OK because
most of the partners don't have that url.
(Assignee)

Comment 14

17 years ago
A null value or an empty string is fine for the customize url.

Comment 15

17 years ago
Linda, I believe our current documentation has it like this:

window.sidebar.addPanel (document.title, "http://....", "");

so we are probably OK as far as the documentation is concerned.

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 16

17 years ago
verified this is fixed on win/mac/linux builds 2000090508m18.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.