Closed Bug 501921 Opened 12 years ago Closed 12 years ago

Comma separated displayname containing Swedish characters not handled correctly

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 254519

People

(Reporter: spamlover, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.21 (20090302)

Receiving an e-mail where the senders displayname is formatted "Lastname, Firstname" and firstname contains any of the Swedish characters "ÅÄÖ", Thunderbird treats it as two different senders.
The result is "Lastname", "Firstname" <firstname.lastname@domain.com>. Only the field after comma gets an SMTP-address.

Trying to reply to one of these e-mail messages results in two recipients being inserted. One is just for "Lastname" without any associated SMPT-address, and one is "Firstname" with the correct SMTP-address tied to it.

Tried both English and Swedish version of Thunderbird.

Reproducible: Always

Steps to Reproduce:
1. Format sending e-mail with displayname format: "Lastname, Firstname" and make sure firstname contains "Å, Ä, or Ö".
2. Send to recipient
3. Observe result and try to reply
Actual Results:  
Treated as two different senders and only one of them gets an SMTP-address.

Expected Results:  
Should be seen as ONE sender.
E-mail sent from an Exchange 2003 server.
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491832
(In reply to comment #2)

Ludovic, what is evidence/base that this bug is Dup of bug 491832?
1. You know that comment #0 is for next (a), is never for next (b)/(c)?
   (a) RFC2047-encoded-word-with-=2c <aaa@xxx.yyy.zzz>
   (b) "Lastname, ..Å...Ä...Ö..."    <aaa@xxx.yyy.zzz>
   (c) Lastname, ..Å...Ä...Ö...      <aaa@xxx.yyy.zzz>
2. Even if problem like comment #0 never occurs when (b) and occurs only when (a),
   and even if possibility of (c) is absolutely ZERO,
   Bug 491832 is for problem after patch for Bug 254519 is landed on Tb trunk.
   AFAIK, Bug 491832 will never occur with Tb 2, because patch for Bug 254519
   is not landed on Tb 2.
   Do you know that Bug 491832 occurs on Tb 2 too?
   Or "Build Identifier: version 2.0.0.21 (20090302)" in comment #0 has
   no meaning in this bug report's case?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Sorry for my late reply.
Yes, looks like a duplicate.
(In reply to comment #5)
> Sorry for my late reply.
> Yes, looks like a duplicate.

Better later than never :-) Thanks !
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 254519
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.