drag and drop from external apps to firefox malfunctions (Drag&Drop of link from Thunderbird 2 to Firefox 3.5)

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: jernejcoder, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Drag and drop from external apps to firefox does not work correctly, dragging a link from a email viewed in thunderbird into tab bar of firefox tries to load a double url, in address bar it enters the same link text twice which causes a lot of problems. 
 
I'm using latest firefox 3.5 and thunderbird 2.0.0.22 (20090605) 
 
This is a regression, this worked properly in firefox 3.0. 
 

Reproducible: Always

Steps to Reproduce:
1. open firefox
2. open a email with link in thunderbird
3. drag the link from thunderbird email into firefox tabs bar
Actual Results:  
url of the link that firefox opens is repeated twice, which causes a lot of problems.

Expected Results:  
the link should load properly in the new tab.

i'm running two separate firefox processes with separate profiles if that affects anything.

Comment 1

9 years ago
I can confirm.

Data flavor is text/plain and drag data may be like LinkURL\nLinktext (\n separated value).
Then, Firefox will try to open LinkURL and Linktext as url.

In this case, it should be only LinkURL that it is opened.

Updated

9 years ago
Duplicate of this bug: 502178
(In addition to comment #1)
> Data flavor is text/plain and drag data may be like LinkURL\nLinktext (\n separated value).

(Drag&Drop from Tb 2/Sm 1 to Fx 3.5 on MS Win)
(a) Drop at <textarea> of an HTML page (\n looks to be kept)
LinkURL\n
Linktext
(b) Drop at Seacrh Box (\n looks to be converted to space)
LinkURL Linktext
(c) Drop at URL Box(\n looks to be omitted)
LinkURLLinktext

Confirming.

Both Search Box & URL Box is <input> type(single line box). Improvement of (b) produced problem of (c) at URL Box?
Status: UNCONFIRMED → NEW
Ever confirmed: true
URL: any
Version: unspecified → 3.5 Branch
If the flavor is text/plain, then this is a Thunderbird bug. Can somebody reproduce this with Tb3?
If Drag of a link in HTML mail from Tb 3(2009/7/06 build on MS Win), only LinkURL was displayed at any of (a), (b), (c) in comment #5.
-> invalid
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Summary: drag and drop from external apps to firefox malfunctions. → drag and drop from external apps to firefox malfunctions (Drag&Drop of link from Thunderbird 2 to Firefox 3.5)

Updated

9 years ago
Duplicate of this bug: 514457
You need to log in before you can comment on or make changes to this bug.