Closed Bug 502389 Opened 12 years ago Closed 12 years ago

Thunderbird should make use of titlemodifier and titlemenuseparator attributes on the main and message windows

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Attached patch The fixSplinter Review
On the messenger and message window elements we have had the attributes titlemodifier and titlemenuseparator for quite a while. We don't currently use them, but I think we should - as this enables us to do some build hacks to expand the title (bug 481374) for alpha/beta releases, and allows extensions to tweak things as well (e.g. nightly tester tools).

Simple patch applied to switch over, I've tested on Linux and Mac and everything looks fine. For the case of a tab with no title, I used the following in the error console to get one to open with about:blank :

Components.classes['@mozilla.org/appshell/window-mediator;1'].getService(Components.interfaces.nsIWindowMediator).getMostRecentWindow("mail:3pane").document.getElementById("tabmail").openTab("contentTab", {contentPage: "about:blank"});

I'm trying to get this in before b3 as we'd like it for bug 481374 (neither of which are blocking, but bug 481374 reduces the work build automation has to do and therefore would be nice to get in for b3 so we can test them together).
Attachment #386833 - Flags: review?(mkmelin+mozilla)
Target Milestone: --- → Thunderbird 3.0b3
Attachment #386833 - Flags: review?(mkmelin+mozilla) → review+
Comment on attachment 386833 [details] [diff] [review]
The fix

Looks good to me! r=mkmelin
Checked in: http://hg.mozilla.org/comm-central/rev/b444f4f57383
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Depends on: 593321
Duplicate of this bug: 500006
You need to log in before you can comment on or make changes to this bug.