default email client check not launched after install or restart

RESOLVED WORKSFORME

Status

Thunderbird
OS Integration
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Ken Saunders, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 WebSlideShow/1.3.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1pre) Gecko/20090709 Shredder/3.0b3pre

Windows Vista-
Default email client check popup does not appear after clean install (with a new profile), and it does not appear after restarting Shredder, or when setting a different email client as default then launching Shredder despite the selection made to run the check in "System Integration - Always check to see if Shredder is the default mail client on startup".

It does function as the default email client when set to be through Shredder and/or through Windows Default Programs settings, but the popup never appears.




Reproducible: Always

Steps to Reproduce:
Case 1
1. Install then launch Thunderbird 3.0b3pre 

Case 2
1. Go to > Tools > Options > Advanced > General
2. Make sure that "Always check to see if Shredder is the default mail client on startup" is checked.
3. Restart 

Case 3
1. Remove Shredder as the default email program (leave "Always check to see..." checked).
2. Set a different email client as the default one.
3. Launch Shredder


Actual Results:  
The default email client check popup never appears in any of the cases above

Expected Results:  
The default email client check popup should always appear.

I was certain to remove Thunderbird 2 as the default email client when testing Shredder and there wasn't any leftover old files or instances of Shredder (profiles, registry or other) when I ran a default email client testcase for Shredder with a (2nd) clean install.

This is apparently a Shredder-Vista issue because the the same feature/function works properly and as expected in Thunderbird 2.0.0.22
(Reporter)

Updated

9 years ago
Blocks: 502621

Updated

9 years ago
Version: unspecified → Trunk

Updated

9 years ago
Keywords: regression
WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090828 Lightning/1.0pre Shredder/3.0b4pre ID:20090828110904

Reporter could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?
(Reporter)

Comment 2

9 years ago
Will do.

I'm going to first look up the Litmus testcase that failed to follow the steps to perform so that I don't miss anything.

Comment 3

9 years ago
Ken, change to WFM?
Ken Saunders (reporter), is this still a problem with tb16 or can we close this "worksforme"?
Flags: needinfo?(KenSaunders)
(Reporter)

Comment 5

6 years ago
Hey, sorry for the delay.

I'm on Win7 now but WFM is appropriate.

I just confirmed this.
I was prompted after a new install as well as when I updated to 17.0. 
Perhaps because of the additional installation?
No matter, it works.
Flags: needinfo?(KenSaunders)
Thanks Ken for quick & helpful feedback!

wfm per reporter's comment 5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.