[SeaMonkey 2.1] autocomplete / password manager broken

VERIFIED FIXED in seamonkey2.0b2

Status

SeaMonkey
Passwords & Permissions
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: sgautherie, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug, {regression, testcase})

Trunk
seamonkey2.0b2
x86
Windows 2000
regression, testcase
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.1pre) Gecko/20090711
SeaMonkey/2.0b1pre] (comm-1.9.1-win32-unittest/1247314938) (W2Ksp4)
(http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d3c7a48a5b6a
 +http://hg.mozilla.org/comm-central/rev/291cbe3374b9)
+
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090530 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/e44d9c0f4805
 +http://hg.mozilla.org/comm-central/rev/62f2c362a9a4 + bug 493008 patches)

No bug.


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090711
SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/47bfcd275ede
 +http://hg.mozilla.org/comm-central/rev/291cbe3374b9)

When I type in the first letter of my username, (to login on a site),
the dropdown list appears as expected under the text box,
but the entries are blank and can't be selected.
(Reporter)

Comment 1

9 years ago
Ah, see bug 500298 comment 3...
No longer blocks: 470184
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500298
(Reporter)

Updated

9 years ago
Depends on: 500298
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> *** This bug has been marked as a duplicate of bug 500298 ***

From that bug:

{
Description
From  Grey Hodge (jX)   2009-06-24 14:48:42 PDT

Changelog (I think) from a working nightly to the broken one:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c575412d976a&tochange=5fe89f2c22f0


Comment 3
From  Ted Mielczarek (:luser) [vacation July 9-20]   2009-06-25 10:42:54 PDT

Simple testcase:
data:text/html,<form action=""><input type="text" name="q"></form>


Comment 6
From  Serge Gautherie (:sgautherie)   2009-07-13 09:08:48 PDT

Fix timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5fe89f2c22f0&tochange=968dfbf1cee9
Does anyone know which of these changesets fixed this bug?
}

*****

(No previous nightlies.)

No dropdown at all:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090712 SeaMonkey/2.1a1pre
2009-07-12-06-comm-central-trunk; http://hg.mozilla.org/mozilla-central/rev/628c8764ade1
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090712 SeaMonkey/2.1a1pre
2009-07-12-14-comm-central-trunk; http://hg.mozilla.org/mozilla-central/rev/0f8a08ec7c90
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090713 SeaMonkey/2.1a1pre
2009-07-13-01-comm-central-trunk; http://hg.mozilla.org/mozilla-central/rev/66470e0d29ca

It looks like something needs to be ported from Firefox to SeaMonkey.
Status: RESOLVED → REOPENED
Keywords: testcase
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

9 years ago
(In reply to comment #0)
> [Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090711
> SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
> (http://hg.mozilla.org/mozilla-central/rev/47bfcd275ede
>  +http://hg.mozilla.org/comm-central/rev/291cbe3374b9)

I get lots of errors like:

80657 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/passwordmgr/test/test_basic_form_autocomplete.html | Checking form1 username - got "", expected "tempuser1"

81630 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/satchel/test/test_form_autocomplete.html | Checking length of expected menu - got 0, expected 4
81631 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/components/satchel/test/test_form_autocomplete.html | Checking menu entry #0 - got undefined, expected "value1"

Justin, any hint?
Blocks: 470184
Status: REOPENED → NEW
(Reporter)

Updated

9 years ago
Summary: [SeaMonkey 2.1] Login list appears, but with "blank" entries → [SeaMonkey 2.1] autocomplete / password manager broken
(Reporter)

Updated

9 years ago
Blocks: 452942
(Reporter)

Updated

9 years ago
Duplicate of this bug: 503793
(Reporter)

Comment 5

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/3eb25c0c2bfe
 +http://hg.mozilla.org/comm-central/rev/16d18598cb19)

Regression timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c575412d976a&tochange=3eb25c0c2bfe
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)

Already failing.

***

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/367085602a38
 +http://hg.mozilla.org/comm-central/rev/16d18598cb19)

Already failing.

Regression timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c575412d976a&tochange=367085602a38
(Reporter)

Comment 7

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/8d5c08070a23
 +http://hg.mozilla.org/comm-central/rev/16d18598cb19)

Already failing.

Regression timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c575412d976a&tochange=8d5c08070a23
That would be bug 497178, then. (Let me confirm it.)
(Reporter)

Comment 8

9 years ago
(In reply to comment #7)
> That would be bug 497178, then. (Let me confirm it.)

It's not.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/96af54657102
 +http://hg.mozilla.org/comm-central/rev/16d18598cb19)

Already failing.

Regression timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c575412d976a&tochange=96af54657102
Oh, this leaves only bug 493601, which seems unlikely to me ... or it regressed earlier on SM than on FF!?
(Reporter)

Comment 9

9 years ago
(In reply to comment #8)
> Oh, this leaves only bug 493601, which seems unlikely to me ... or it regressed
> earlier on SM than on FF!?

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/c575412d976a
 +http://hg.mozilla.org/comm-central/rev/16d18598cb19)

Already failing.

Regressed earlier, then! :-<
(Reporter)

Comment 10

9 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)

(http://hg.mozilla.org/mozilla-central/rev/1cfe7ecbb88f
 +http://hg.mozilla.org/comm-central/rev/8cc20299e7c3)
(http://hg.mozilla.org/mozilla-central/rev/1057ca8f2a91
 +http://hg.mozilla.org/comm-central/rev/d1a9b79cf5c2)

Fine.

(http://hg.mozilla.org/mozilla-central/rev/cabb8925dcd3
 +http://hg.mozilla.org/comm-central/rev/d1a9b79cf5c2)
(http://hg.mozilla.org/mozilla-central/rev/baa657668d37
 +http://hg.mozilla.org/comm-central/rev/d1a9b79cf5c2)
(http://hg.mozilla.org/mozilla-central/rev/0102de270b20
 +http://hg.mozilla.org/comm-central/rev/9c990709ec02)
(http://hg.mozilla.org/mozilla-central/rev/7192582eb846
 +http://hg.mozilla.org/comm-central/rev/9c990709ec02)
(http://hg.mozilla.org/mozilla-central/rev/d616a84cad24
 +http://hg.mozilla.org/comm-central/rev/011acc33c8f6)

Broken.

Regression timeframe:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1057ca8f2a91&tochange=cabb8925dcd3
2 changesets:
bug 488846 is Firefox only,
then this is a "Bug 178324, refactor focus" fallout.
Blocks: 178324
I can't really follow your regression range methodology.

Bug 178324 landed a month before this bug was filed. Has Seamonkey trunk been failing tests since then?
(Reporter)

Comment 12

9 years ago
(In reply to comment #11)
> I can't really follow your regression range methodology.

I started from the Firefox regression timeframe ... which eventually did not apply to SeaMonkey...

> Bug 178324 landed a month before this bug was filed. Has Seamonkey trunk been
> failing tests since then?

SeaMonkey got mozilla-central build boxes only a few days ago ... which is why I have to do all the builds locally.

And it does not have mozilla-central unit test boxes yet...
(I haven't run the tests on all the regression builds: I checked the testcase and real sites only yet.)

Comment 13

9 years ago
I seem to recall Neil R. had looked into this some time back. Don't recall what the outcome was though.
(Reporter)

Comment 14

9 years ago
Fwiw, Firefox bug 500298 was fixed by (re-landing fixed) bug 495983.

To summarize, the symptom is the "same" but the "triggering cause" is different.
Keywords: helpwanted
(Assignee)

Comment 15

9 years ago
Created attachment 388768 [details] [diff] [review]
Patch as recommended by Enn

I almost forgot about this... Enn told me to do this over IRC, and it works.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #388768 - Flags: review?(enndeakin)

Updated

9 years ago
Attachment #388768 - Flags: review?(enndeakin) → review+
(Reporter)

Comment 16

9 years ago
Comment on attachment 388768 [details] [diff] [review]
Patch as recommended by Enn


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2)

I confirm this patch fixes both tests.
(Assignee)

Comment 17

9 years ago
Pushed changeset 70880f5ed4e2 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED

Comment 18

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090719 SeaMonkey/2.1a1pre - Build ID: 20090719121

Fixed in hourlies.
(Reporter)

Comment 19

9 years ago
V.Fixed
Status: RESOLVED → VERIFIED
Keywords: helpwanted
Target Milestone: --- → seamonkey2.0b2
You need to log in before you can comment on or make changes to this bug.