If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Contents of body is changed when forwarded. Not when replied.

VERIFIED DUPLICATE of bug 307023

Status

Thunderbird
General
--
major
VERIFIED DUPLICATE of bug 307023
8 years ago
8 years ago

People

(Reporter: marc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1b3pre) Gecko/20090223 Lightning/1.0pre Thunderbird/3.0b2

When the e-mail underneath is forwarded a characters are removed.  This is not done when replying to the message.

<begin e-mail>
Return-Path: <nospam@nospam.be>
Delivered-To: nospam@nospam.be
Message-Id: <85033B02-F702-41B2-9494-93638AC34B89@nospam.be>
From: nospam nospam <nospam@nospam.be>
To: nospam@nospam.be
Content-Type: multipart/alternative; boundary=Apple-Mail-45-744021100
Mime-Version: 1.0 (Apple Message framework v930.3)
Subject: Fwd: subject
Date: Mon, 13 Jul 2009 14:04:36 +0200
References: <CAB92773-EC9E-47A4-BF74-2DA134EBC3C0@nospam.be>
X-Mailer: Apple Mail (2.930.3)


--Apple-Mail-45-744021100
Content-Type: text/plain;
  charset=ISO-8859-1;
  format=flowed;
  delsp=yes
Content-Transfer-Encoding: quoted-printable

D=E9but du message r=E9exp=E9di=E9 :

> Format : 1/4 page quadri =3D 141H x 100L
> Format : Art. 125 V quadri =3D 135H x 89L
>



--Apple-Mail-45-744021100
Content-Type: multipart/related;
  boundary=Apple-Mail-46-744021101;
  type="text/html"


--Apple-Mail-46-744021101
Content-Type: text/html;
  charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<html><body style=3D"word-wrap: break-word; -webkit-nbsp-mode: space; =
-webkit-line-break: after-white-space; "><div><div>D=E9but du message =
r=E9exp=E9di=E9 :</div><br class=3D"Apple-interchange-newline"><blockquote=
 type=3D"cite"><div><div style=3D"margin-top: 0px; margin-right: 0px; =
margin-bottom: 0px; margin-left: 0px; "><font face=3D"Helvetica" =
size=3D"3" color=3D"#000000" style=3D"font: 12.0px Helvetica; color: =
#000000"><div>Format : 1/4 page quadri =3D 141H x = 100L</div><div>Format=
: Art. 125 V quadri =3D 135H x = 89L</div>
</body></html>=

--Apple-Mail-46-744021101--

--Apple-Mail-45-744021100--
<end e-mail>


Reproducible: Always

Steps to Reproduce:
1. forward the e-mail.

Actual Results:  
The 2 characters after '=' are removed.

Comment 1

8 years ago
Looks like bug 307023, however I don't see an image in the HTML part.
Can you retest with a 3.0b3pre nightly build if this still applies?

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
(Reporter)

Comment 2

8 years ago
Hi rsx11m, thanks for your reply.

I tested with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090323 Lightning/1.0pre Shredder/3.0b3pre
and the result was the same.
When opening the bug i pasted the source of the e-mail into the posting.  So you can create an e-mail file and open it in Thunderbird.  When forwarding you'll see that a few characters will be missing.

Comment 3

8 years ago
The final patch for this bug got checked in on 2009-04-15, thus you won't see
it in the  2009-03-23 nightly build you have used. I've just put your message into the current 2009-07-15 Shredder nightly and don't see any tag or attribute corruption when forwarding inline. Thus, I'd assume that this is a special case of bug 307023 and can be considered fixed.

Please double-check with today's nightly, then we can close the bug unless you find anything else.
(Reporter)

Comment 4

8 years ago
I tried version
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090714 Lightning/1.0pre Shredder/3.0b3pre

The problem is solved in this version.

Thanks a lot.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 5

8 years ago
You are welcome, marking as duplicate of the original bug.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 307023
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.