Closed Bug 503869 Opened 13 years ago Closed 13 years ago

Electrolysis revision doesn't display properly

Categories

(mozilla.org Graveyard :: Server Operations, task)

x86
Linux
task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: benjamin, Assigned: aravind)

References

()

Details

Attachments

(1 file)

http://hg.mozilla.org/projects/electrolysis/rev/17c4987e08e3

This webpage doesn't display properly. Can you look in the logs to see if there's a python error message or some other clue what's going on?

This is not necessarily a regression from hg 1.2 because I just committed this change, but it could be related.
>[Mon Jul 13 09:34:45 2009] [error] [client 10.2.74.13] mod_wsgi (pid=5440): Exception occurred processing WSGI script '/repo/hg/webroot_wsgi/projects/hgwebdir.wsgi'.
>Traceback (most recent call last):
>  File "/usr/lib/python2.4/site-packages/mercurial/util.py", line 319, in increasingchunks
>    for chunk in source:
>  File "/usr/lib/python2.4/site-packages/mercurial/templater.py", line 148, in expand
>    item = iters[0].next()
>  File "/usr/lib/python2.4/site-packages/mercurial/util.py", line 319, in increasingchunks
>    for chunk in source:
>  File "/usr/lib/python2.4/site-packages/mercurial/templater.py", line 144, in expand
>    tmpl = self._template(t)
>  File "/usr/lib/python2.4/site-packages/mercurial/templater.py", line 92, in _template
>    self.cache[t] = file(self.map[t]).read()
>KeyError: 'filenolink'
djc, any clues?
I think filenolink is a relatively new template string that might not be in gitweb_mozilla? Not sure, but I remember changing something in that department.
Duplicate of this bug: 503910
Assignee: server-ops → dirkjan
Status: NEW → ASSIGNED
Attachment #388282 - Flags: review?
Attachment #388282 - Flags: review? → review?(benjamin)
Attachment #388282 - Flags: review?(benjamin) → review+
Pushed aa61bbb873b2 to hg_templates. Ops, can you deploy?
Assignee: dirkjan → server-ops
Assignee: server-ops → aravind
Done.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.