Since Bug 398170 clicking on a label in the Permissions tab does not focus on the radio buttons.

RESOLVED FIXED

Status

()

Firefox
Page Info Window
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Philip Chee, Assigned: MarcoZ)

Tracking

({access, regression, verified1.9.1})

Trunk
access, regression, verified1.9.1
Points:
---

Firefox Tracking Flags

(status1.9.1 .4-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
+++ This bug was initially created as a clone of Bug #398170 +++

From Bug 491835 Comment 5 (From  Gavin Sharp):

>>> Firefox are getting good at this ;-)
>> Well I did fix the broken ARIA/focus stuff that I fixed in the rest of our
>> Permissions tab, and that is still broken in Firefox ;-)
> 
> Have you filed a bug?

From Bug 491310 Comment 10:

> Created an attachment (id=377859)
> Patch v1.2 Use aria-labelledby
> 
> Marco says in Comment 6:
> 
>> b) The label simply assigns the accessible name to both the radiogroup and the
>> "virtual" group created under a). The focusable element is, however, only the
>> radiogroup element so that the behavior is that if you click the label, you
>> should be redirected to the radio buttons.
> 
> Neil says in Comment 8:
> 
>>> the behavior is that if you click the label, you
>>> should be redirected to the radio buttons.
>> This is certainly the behaviour before the patch, but not with patch v1.0
> 
> I've switched to using aria-labelledby="label_id" which gets rid of the twee
> control bit, restores the focus to the radio buttons. I think that this should
> work for screen readers but I can't tell so I'm asking Marco to review the ARIA
> changes.
Philipp, thanks for filing a followup bug against Firefox on this issue! Are you going to submit a patch?
(Reporter)

Comment 2

9 years ago
> Are you going to submit a patch?
Since this doesn't affect SeaMonkey, No I'm not.
All right, then I'll take this one!
Created attachment 388471 [details] [diff] [review]
Patch

Backport from what was done in SeaMonkey bug 491310, plus the addition for the GeoLocation part.
Assignee: nobody → marco.zehe
Status: NEW → ASSIGNED
Attachment #388471 - Flags: review?
Attachment #388471 - Flags: review? → review?(gavin.sharp)
Attachment #388471 - Flags: review?(gavin.sharp) → review+
Pushed to m-c:
http://hg.mozilla.org/mozilla-central/rev/d06b2e7263af
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Comment on attachment 388471 [details] [diff] [review]
Patch

trivial XUL markup fix.
Attachment #388471 - Flags: approval1.9.1.2?
Attachment #388471 - Flags: approval1.9.1.2? → approval1.9.1.3?
Keywords: regression
Comment on attachment 388471 [details] [diff] [review]
Patch

Approved for 1.9.1.4, a=dveditz for release-drivers
Attachment #388471 - Flags: approval1.9.1.3? → approval1.9.1.4+
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090827 Shiretoko/3.5.4pre (.NET CLR 3.5.30729)
Keywords: verified1.9.1
You need to log in before you can comment on or make changes to this bug.