Last Comment Bug 504281 - SVN Account Request - Seong-wook Gong <arbi316@gmail.com>
: SVN Account Request - Seong-wook Gong <arbi316@gmail.com>
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Justin Lazaro [:jlaz]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 02:00 PDT by Seong-wook Gong
Modified: 2010-06-17 02:18 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
My SSH private key for Putty (843 bytes, text/plain)
2009-07-19 22:52 PDT, Seong-wook Gong
no flags Details
This is public key. isn't it invalid? (294 bytes, application/octet-stream)
2009-07-19 23:09 PDT, Seong-wook Gong
no flags Details
re-upload public key for SSH2-RSA format. please make it to authentication (294 bytes, text/plain)
2009-07-19 23:31 PDT, Seong-wook Gong
no flags Details
SSH key in OpenSSH format (209 bytes, text/plain)
2010-04-16 11:00 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details
New SSH-DSA-pub-key (680 bytes, application/octet-stream)
2010-06-16 10:15 PDT, Seong-wook Gong
no flags Details
New SSH-DSA-pub-key (re-uploaded) (681 bytes, text/plain)
2010-06-16 10:22 PDT, Seong-wook Gong
no flags Details
New SSH-DSA-pub-key (re-uploaded #2) (606 bytes, text/plain)
2010-06-16 10:28 PDT, Seong-wook Gong
no flags Details

Description Seong-wook Gong 2009-07-15 02:00:19 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ko; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ko; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

I wanna SVN Account for localizing AMO ko site.
Too many strings are still displaying in english

I need write access to the following locations:
http://svn.mozilla.org/addons/trunk/site/app/locale/ko/

Thanks

Reproducible: Didn't try
Comment 1 Marcia Knous [:marcia - use ni] 2009-07-15 14:30:55 PDT
You will need to submit the Committer's agreement to Erica and attach an SSH key to the bug.  Also will need a voucher -> https://wiki.mozilla.org/Commit_Policy:Current_Procedures shows the list of people who can vouch for that area.

http://www.mozilla.org/hacking/committer/committers-agreement.pdf is where you can find the Committer's agreement.
Comment 2 Erica McClure 2009-07-16 08:08:29 PDT
I have received Seonguk's Committer's Agreement.
Comment 3 Seong-wook Gong 2009-07-19 22:09:28 PDT
(In reply to comment #2)
> I have received Seonguk's Committer's Agreement.

When am I able to use my SVN account?
Comment 4 Seong-wook Gong 2009-07-19 22:52:28 PDT
Created attachment 389420 [details]
My SSH private key for Putty
Comment 5 Reed Loden [:reed] (use needinfo?) 2009-07-19 22:54:55 PDT
Comment on attachment 389420 [details]
My SSH private key for Putty

Guh, you should never give out your private key. This private key is completely worthless now. You need to regenerate a new key and post the public (.pub) portion of the key.
Comment 6 Seong-wook Gong 2009-07-19 23:09:54 PDT
Created attachment 389421 [details]
This is public key. isn't it invalid?
Comment 7 Seong-wook Gong 2009-07-19 23:31:36 PDT
Created attachment 389425 [details]
re-upload public key for SSH2-RSA format. please make it to authentication
Comment 8 Channy Yun [:channy] 2009-07-20 02:16:07 PDT
Thankfully Mr. Gong recently contributed a translation of new messages for AMO 5.0.7. I committed his jobs to addon repository. 

But, I'm not sure whether he's good at commit rules and svn usage to get vouch or not. It seems to be needed more jobs by him and time. I personally emailed to explained to him.

I suggest this bug to be fixed by "resolved incomplete" and I'll reopen this bug if he is prepared.
Comment 9 Seong-wook Gong 2009-07-20 04:20:36 PDT
(In reply to comment #8)
> Thankfully Mr. Gong recently contributed a translation of new messages for AMO
> 5.0.7. I committed his jobs to addon repository. 
> 
> But, I'm not sure whether he's good at commit rules and svn usage to get vouch
> or not. It seems to be needed more jobs by him and time. I personally emailed
> to explained to him.
> 
> I suggest this bug to be fixed by "resolved incomplete" and I'll reopen this
> bug if he is prepared.
I understand. Thanks for answer
Comment 10 Wil Clouser [:clouserw] 2009-07-20 08:29:30 PDT
Thank you both for your contributions.  Seonguk, it's standard practice for contributers to add patches to bugs and work through other people who have commit access for a while.  Since that's Channy's recommendation we'll go with that for the time being.

Thanks!
Comment 11 Channy Yun [:channy] 2010-03-24 21:22:36 PDT
I want to recommend Mr. Gong as a Korean localizer of Add-ons and getpersona. He has been tireless contributions for a year and I think he has sufficient to do this work. Please reopen this bug and process it for svn.mozilla.org.
Comment 12 Erica McClure 2010-04-15 09:52:58 PDT
I have received Seonguk's Committer's Agreement.
Comment 13 Wil Clouser [:clouserw] 2010-04-15 10:04:44 PDT
a=clouserw for svn.mozilla.org/addons/trunk/site/app/locale/ko/
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-04-16 11:00:35 PDT
Created attachment 439572 [details]
SSH key in OpenSSH format

This is the output of:
curl https://bug504281.bugzilla.mozilla.org/attachment.cgi?id=389425 2>/dev/null | ssh-keygen -i -f /dev/stdin

(IT needs the pubkey in OpenSSH format)
Comment 15 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-04-16 11:02:26 PDT
Over to IT for an SVN account with authz changes for:

svn.mozilla.org/addons/trunk/site/app/locale/ko/
Comment 16 Justin Lazaro [:jlaz] 2010-04-16 16:34:07 PDT
arbi316@gmail.com LDAP account created with 
rw for svn.mozilla.org/addons/trunk/site/app/locale/ko/

-jlazaro
Comment 17 Seong-wook Gong 2010-05-04 12:03:15 PDT
I can't commit messages.po and mo files

error message - Can't open 'repo/svn/mozilla/db/tempfile.tmp': Permission denied

How can I deal with this problem?
Comment 18 Wil Clouser [:clouserw] 2010-05-04 12:11:30 PDT
what does 'svn status' say?
Comment 19 Seong-wook Gong 2010-05-04 19:20:50 PDT
(In reply to comment #18)
> what does 'svn status' say?

What's svn status? I'm using tortoise svn client. Where can I find it out?
Comment 20 Wil Clouser [:clouserw] 2010-05-04 19:51:07 PDT
I don't know about Tortoise.  Make sure you are checked out over https and not http.  https://wiki.mozilla.org/SVN might help.
Comment 21 Seong-wook Gong 2010-05-04 21:46:54 PDT
(In reply to comment #20)
> I don't know about Tortoise.  Make sure you are checked out over https and not
> http.  https://wiki.mozilla.org/SVN might help.

I'd used svn on cygwin. I type 'svn commit --file msg.txt messages.po' to commit messages.po file but server request username and password.

I assume it is LDAP account and its password however, the server doesn't confirm my LDAP account. My LDAP account is arbi316@gmail.com

I suspect permission issue. The server uses ssh protocol and it means if I can't auth private key even I can't check out. Of course I can check out.
Comment 22 Seong-wook Gong 2010-06-16 10:15:14 PDT
Created attachment 451627 [details]
New SSH-DSA-pub-key

My previous key couldn't write to svn.

So I would upload a new public key.

Please register this key instead old one.

My LDAP Account is arbi316@gmail.com
Comment 23 Seong-wook Gong 2010-06-16 10:22:46 PDT
Created attachment 451628 [details]
New SSH-DSA-pub-key (re-uploaded)

New SSH-DSA-pub-key

My previous key couldn't write to svn.

So I would upload a new public key.

Please register this key instead old one.

My LDAP Account is arbi316@gmail.com
Comment 24 Seong-wook Gong 2010-06-16 10:25:25 PDT
Comment on attachment 451628 [details]
New SSH-DSA-pub-key (re-uploaded)

ssh-dss AAAAB3NzaC1kc3MAAACBAJKkilSmQ9rw86ethFGDNm11QZ03dSYaDU7TiCZDapDDq7mC51hR+HvoHMfZzW11jJMnkI2f4pC+8LEPKl/c9/Ui+9uX2L4lc+H9EvkJQaTMET9OGM+WpOE/sTaZj1CaFCpobLeCW/RokDhDQnNKMLQYLpJioJiLnaprrc7MzmynAAAAFQDbYv9qrAnIIzzIPoPgaafoU8p5EQAAAIA2Sj9FJRxcJVRvKsyInWkeTlElOVFxWdBcp+aV3vMlxFYs6noVlmT8TwYDJkVNVc8J354Hy9O3t8RebrXqx72Y6YhmnxJ/YRCgMNxD2dEOesErnT15v53knRY2BvUrrXl+15oszuLOo7GiSiQ5R3iGolqTunGBhBuISqNJRVA7UgAAAIB0Ks8TW5DJAYg5UV9srJr+9jvvYDk0njtiUIvKsX57GCA96YQXybxvTgzy9zwHXNyV++JkwgarbKGIbKNjjiDMiDZx6/XRNFf55QucvD5++4kS3a+FyIm998Z9MhxXlxdA+Qh4Xn6mm6NKDO2nP/cwD87yT6ed9L0UxBDBu0RKJw== arbi316@gmail.com
Comment 25 Seong-wook Gong 2010-06-16 10:26:29 PDT
Comment on attachment 451628 [details]
New SSH-DSA-pub-key (re-uploaded)

>---- BEGIN SSH2 PUBLIC KEY ----
>Comment: "arbi316@gmail.com"
>AAAAB3NzaC1kc3MAAACBAJKkilSmQ9rw86ethFGDNm11QZ03dSYaDU7TiCZDapDD
>q7mC51hR+HvoHMfZzW11jJMnkI2f4pC+8LEPKl/c9/Ui+9uX2L4lc+H9EvkJQaTM
>ET9OGM+WpOE/sTaZj1CaFCpobLeCW/RokDhDQnNKMLQYLpJioJiLnaprrc7Mzmyn
>AAAAFQDbYv9qrAnIIzzIPoPgaafoU8p5EQAAAIA2Sj9FJRxcJVRvKsyInWkeTlEl
>OVFxWdBcp+aV3vMlxFYs6noVlmT8TwYDJkVNVc8J354Hy9O3t8RebrXqx72Y6Yhm
>nxJ/YRCgMNxD2dEOesErnT15v53knRY2BvUrrXl+15oszuLOo7GiSiQ5R3iGolqT
>unGBhBuISqNJRVA7UgAAAIB0Ks8TW5DJAYg5UV9srJr+9jvvYDk0njtiUIvKsX57
>GCA96YQXybxvTgzy9zwHXNyV++JkwgarbKGIbKNjjiDMiDZx6/XRNFf55QucvD5+
>+4kS3a+FyIm998Z9MhxXlxdA+Qh4Xn6mm6NKDO2nP/cwD87yT6ed9L0UxBDBu0RK
>Jw==
>---- END SSH2 PUBLIC KEY ----
Comment 26 Seong-wook Gong 2010-06-16 10:28:16 PDT
Created attachment 451629 [details]
New SSH-DSA-pub-key (re-uploaded #2)

It's a lastest SSH-DSA-pub-key

My previous key couldn't write to svn.

So I would upload a new public key.

Please register this key instead old one.

My LDAP Account is arbi316@gmail.com
Comment 27 Justin Lazaro [:jlaz] 2010-06-17 02:18:04 PDT
SSH key from comment #26 attached to arbi316@gmail.com, please re-open if you continue to have any trouble 

-jlazaro

Note You need to log in before you can comment on or make changes to this bug.