If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Get rid of the parser/html/javasrc symlink

RESOLVED FIXED

Status

()

Core
HTML: Parser
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: bnewman, Assigned: bnewman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
The HTML5 translator copies java source files from an svn working directory to parser/html/javasrc before translating those copied files.  When I landed the patch for bug 499141, the svn working directory became part of the mozilla-central tree, so I believed the copying step was no longer necessary.  I decided to avoid the copying by making parser/html/javasrc a symlink to the source directory, so that when the translator copied the files it would notice that the sources and destinations were the same, and do nothing.

This was a hack, and, as Henri has argued in https://bugzilla.mozilla.org/show_bug.cgi?id=504442#c2, there is still good reason to copy the java files used for the translation to a distinct directory.
(Assignee)

Comment 1

8 years ago
Created attachment 388977 [details] [diff] [review]
Removing the symlink and updating 'make translate' to create a proper directory

At some point this line in translator-src/.../cpptranslate/Main.java also needs to get uncommented:

    copyFile(new File(javaDirectory, H_LIST[i] + ".java"),
             new File(javaCopyDirectory, H_LIST[i] + ".java"));

Fortunately I was mistaken when I said in my previous comment that the copied files were used to perform the translation.  The copying is more of a side effect, so uncommenting the copyFile line isn't immediately necessary.
Attachment #388977 - Flags: review?(hsivonen)
Attachment #388977 - Flags: review?(hsivonen) → review+
(In reply to comment #1)
> Created an attachment (id=388977) [details]
> Removing the symlink and updating 'make translate' to create a proper directory
> 
> At some point this line in translator-src/.../cpptranslate/Main.java also needs
> to get uncommented:
> 
>     copyFile(new File(javaDirectory, H_LIST[i] + ".java"),
>              new File(javaCopyDirectory, H_LIST[i] + ".java"));

I commented it away because the symlink broke my Eclipse-based workflow. Once the symlink in replaced with a real dir, the line can be uncommented.
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> I commented it away because the symlink broke my Eclipse-based workflow. Once
> the symlink in replaced with a real dir, the line can be uncommented.

Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/58e0c540814c
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 504815
You need to log in before you can comment on or make changes to this bug.