Menues have extra ellipsis

RESOLVED DUPLICATE of bug 610922

Status

()

--
trivial
RESOLVED DUPLICATE of bug 610922
9 years ago
8 years ago

People

(Reporter: quidam, Assigned: migaelm)

Tracking

({polish})

3.5 Branch
x86
Windows Vista
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-easy][polish-visual][polish-p3])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)

The Tools-> Options... should be Tools-> Options 



Reproducible: Always

Steps to Reproduce:
1.Install firefox 3.5.1
2. Open the tools menu
3.look
Actual Results:  
Tools -> Options... is what you see

Expected Results:  
Tools -> Options

http://blogs.msdn.com/oldnewthing/archive/2004/05/17/133181.aspx is a relevant URL
It has always been "Options...".
Version: unspecified → 3.5 Branch
The purpose of the ellipsis is to indicate that no immediate action will take place, and only additional information will be displayed.  So for instance the command "Print" means something will probably come out of your printer, while "Print..." means that you will get to specify additional settings before clicking a button called "Print."

Some HIGs recommend only using an ellipsis when the action is ambiguous, and IE and Chrome just have "options."  Overall I don't really have a strong opinion, adding the ellipsis makes things totally clear and internally consistent, but it is also a bit overkill.
Hm, after reading the Old New Thing blog post:

>Sometimes the dialog box is the command itself, such as "About" or "Properties". >Even though they display a dialog, the dialog is the result

I'm not sure I would have written the HIG this way, but given that is their guidelines, I guess on Windows it is actually worth removing the ellipsis just to be totally consistent with the platform conventions.
Whiteboard: [polish-easy][polish-visual][polish-p3]
(Assignee)

Comment 4

9 years ago
Hey, I'd like take a look at this. This would be my first patch and i feel this is trivial enough for me to learn the basics of creating my first patch. I've checked and this bug (if you can call it a bug) is still present in Firefox 3.5.2.
(Assignee)

Comment 5

9 years ago
Created attachment 392131 [details] [diff] [review]
This is a patch updating the en-US locales to remove the elipses.

It is a single line of code that had to be changed (not that anyone would have expected anything difficult from this :P ) I think the hardest part was to actually get an idea of how the code is structured to find where the bug was located.
Migael, you need to request review on your patch in order to move it forward. I suggest you r? gavin.sharp@gmail.com and ui-r? faaborg@mozilla.com.
(Assignee)

Comment 7

9 years ago
I will do so, thanx...
(Assignee)

Updated

9 years ago
Attachment #392131 - Flags: review?(gavin.sharp)
You'll need to change the entity name as well, to make the change obvious to localizers (unfortunately). Perhaps preferencesCommand.label?
Assignee: nobody → migaelm
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

9 years ago
That makes sense, I'll have a look at that...
Attachment #392131 - Flags: review?(gavin.sharp)

Comment 10

9 years ago
FWIW of the Microsoft software I have on this XPSP3 machine, Windows Explorer, MS Excel 2000, Wordpad, Outlook Express, WinDbg, Microsoft FxCop and Visual Studio 2008 all use an ellipsis for Options, only IE8 doesn't.

I think either is valid given the linked blog entry, since you might be going into Options to see how Fx is currently set up (in which case the Options dialog itself is the goal), or you might be going to Options to change something (in which case the Options dialog is asking for the relevant information before performing the change).

If it's decided to remove this ellipsis then I think for consistency's sake that the ellipsis should also be removed from the Organize Bookmarks menu (which can also be seen as either a goal in its own right or a means to make a change).
Keywords: polish

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610922
You need to log in before you can comment on or make changes to this bug.