Closed Bug 610922 Opened 9 years ago Closed 9 years ago

"Options..." and "Show All Bookmarks..." should not end with an ellipsis

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 4.0b8

People

(Reporter: faaborg, Assigned: fryn)

References

(Blocks 1 open bug)

Details

(Whiteboard: [strings])

Attachments

(1 file, 1 obsolete file)

The menu commands "Options..." and "Show All Bookmarks..." both currently end with an ellipsis, even though the command is carried out as soon as the user selections the option without needing any further input. (As an example "About Firefox" also does not use an ellipsis).

Even if we can't break string freeze, we may want to update these for en-us and then try to update them for other locals later.  "Options..." stands out right now since it is the only item in the right pane that contains an ellipsis (even though every item in that pane loads a tab or window).  And "Show All Bookmarks..." isn't internally consistent with the related command "Show All History"
Summary: "Options" and "Show All Bookmarks" should end with an ellipsis → "Options..." and "Show All Bookmarks..." should not end with an ellipsis
Assignee: nobody → fryn
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86 → All
Version: unspecified → Trunk
Attached patch patch for en-US (obsolete) — Splinter Review
took it because I get annoyed by inconsistencies like this :P
Attachment #489410 - Flags: review?(dolske)
Switching bug markup to [strings] whiteboard.

I don't think we should do this with "just en-US tweaking", some localizers are going to find it and complain, for one.

Also, a bug is either important to fix or not.
Keywords: late-l10n
Whiteboard: [strings]
>Also, a bug is either important to fix or not.

makes sense, sorry about catching this so late in the process
Comment on attachment 489410 [details] [diff] [review]
patch for en-US

Yeah, what Pike said. Should rev the entities so it gets picked up by l10n.

Do the l10n tools show localizers the previous value of the string? That would be nice so it's clear that the only change is the ellipsis-removal.
Attachment #489410 - Flags: review?(dolske) → review-
Durr, I guess they wouldn't, since there's not really a way to know that the two entity names are related.

Another reason to hate the entity-name-changing system.
Well, they kinda do, if you're looking at https://l10n-stage-sj.mozilla.org/dashboard/compare?run=104442 for example, you see that it says "this goes away, this is new". Humans are OK to guess on related entry names to be related strings.

It doesn't show the difference between the two en-US strings, though.

Then again, one of your localizer uses three-way merge tools to do l10n for a reason ;-).

But yeah, room for improvement, and we're having that on our mind for l20n.
Attached patch patchSplinter Review
Revs the entities.

Mac will still get the ellipsis after Preferences for platform consistency.
Attachment #489410 - Attachment is obsolete: true
Attachment #490696 - Flags: review?(dolske)
Attachment #490696 - Flags: review?(dolske)
Attachment #490696 - Flags: review+
Attachment #490696 - Flags: approval2.0+
Pushed.

http://hg.mozilla.org/mozilla-central/rev/76b44542c5c7
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to comment #9)
> Had to fix a typo.
> 
> http://hg.mozilla.org/mozilla-central/rev/d1228efe31dd

Why are you modifying content in testing/tools/profiles/createTestingProfile.py?
(In reply to comment #10)
> (In reply to comment #9)
> > Had to fix a typo.
> > 
> > http://hg.mozilla.org/mozilla-central/rev/d1228efe31dd
> 
> Why are you modifying content in
> testing/tools/profiles/createTestingProfile.py?

That was to re-land a line that I backed out from another patch that I simultaneously pushed before I figured out what actually was causing the bustage.
See http://hg.mozilla.org/mozilla-central/rev/bacd5fbd6456
and http://hg.mozilla.org/mozilla-central/rev/90cbd8bf83e2
More detail from #developers, 
<fryn> Pike: the pref was removed by my patch, so i removed all instances of it in our code base.
which is part of bug 604419.
Target Milestone: --- → Firefox 4.0b8
Depends on: 616129
Duplicate of this bug: 505341
Blocks: 255051
Verified fixed with Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101202 Firefox/4.0b8pre

Updates Litmus tests:
https://litmus.mozilla.org/show_test.cgi?id=10033
https://litmus.mozilla.org/show_test.cgi?id=10032
Status: RESOLVED → VERIFIED
Flags: in-litmus+
You need to log in before you can comment on or make changes to this bug.