The default bug view has changed. See this FAQ.

[I18N/ENDER]Japanese subject header input does not work

VERIFIED DUPLICATE of bug 6262

Status

MailNews Core
Internationalization
P3
major
VERIFIED DUPLICATE of bug 6262
18 years ago
9 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DEPEND - Intl - QA BLOCKER)

(Reporter)

Description

18 years ago
** Observed with 4/13/99 Win32 build **

When I tried to input Japanese into the mail header field using
Japanese IME on Windows, there is no connection between the IME
and the input field and nothing shows up there.

(We cannot input via copy/paste and this has to be also
 filed as a new bug.)
(Reporter)

Comment 1

18 years ago
Naoki, please set the TM.
(Reporter)

Comment 2

18 years ago
See also Bug 5063 -- copy/paste does not work well for Japanese strings.

Updated

18 years ago
Target Milestone: M5

Comment 3

18 years ago
This is needed for M5 (to support MIME encode for Japanese).
Bob, who should I assgin this, xpfe?

Comment 4

18 years ago
This may related to dom, I added a comment in 5063.

Updated

18 years ago
Assignee: nhotta → pollmann

Comment 5

18 years ago
Reassigning to Eric based upon Vidur's comment in bug 5063.
This is blocking the M5 deliverable for sending Japanese email.

Updated

18 years ago
Assignee: pollmann → rods

Comment 6

18 years ago
This smells like a widget issue to me, and a platform-specific one at that.
Passing to Rod (looks like you did a large amount of the textarea widget work
for windows?).

CC'ing XP Widgets and Linux Widget folks, as this issue probably needs to be
addressed by them as well.
(Assignee)

Comment 7

18 years ago
This is possibly a Windows toolkit bug. Currently, we are using the
MS-Windows standard text and textarea controls within the widget toolkit. I am
not sure why copy/paste of Japanese strings do not work, because that should all
be native windows clipboard stuff.

I can help take a look at this, but I am going to need some help. I don't have a
clue about IME or what is even potentially wrong here.

Comment 8

18 years ago
The forms text widgets are planned to be Ender-based.  Is that correct?
I think we should focus on switching to Ender and not worry about the
intermediate native widget implementation.

Updated

18 years ago
Summary: Japanese subject header input does not work → [I18N/ENDER]Japanese subject header input does not work

Comment 9

18 years ago
Updated Summary by prepending "[I18N/ENDER]" as was done for 5063.

Updated

18 years ago
Whiteboard: QA BLOCKER

Comment 10

18 years ago
Adding to QA Blocker radar.
(Assignee)

Comment 11

18 years ago
I agree with bob, I don't think we should put a lot of effort into this since we
will be moving to Ender text widgets.

Comment 12

18 years ago
Rod,
Can we make the switch by M6?  Isn't this already working in viewer, so
what does it take to get it working in apprunner?  We need this because
the text widget for the mail headers are using forms -- one of the
remaining I18N mail composition problems left.  Also we want to
start testing forms ASAP.  Thanks.
(Assignee)

Comment 13

18 years ago
I am not sure where the editor folks are in getting ender to be the text
widget/control? Greg, do you know?
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → LATER
Target Milestone: M5 → M6
(Assignee)

Comment 14

18 years ago
Moving to M6 and marking as later

Comment 15

18 years ago
Rod,  Shouldn't this be ASSIGNED and not RESOLVED/LATER for M6?

Comment 16

18 years ago
*** Bug 5930 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: RESOLVED → REOPENED
Whiteboard: QA BLOCKER → DEPEND - Intl - QA BLOCKER

Updated

18 years ago
Resolution: LATER → ---
(Reporter)

Comment 17

18 years ago
When this is resolved, testing should include the problem mentioned
in Bug 5930.

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → REMIND

Comment 18

18 years ago
resolving as remind, since we have no plans to test or ship native text
widgets.  Why is this marked as a QA Blocker?  Also, if someone needs to test
5930 when testing this, then 5930 is not a duplicate of this, and should not
have been closed.

Updated

18 years ago
Blocks: 7228

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 19

18 years ago
Should be fixed by Ender-based text widget.  See bug #6262.

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: REMIND → DUPLICATE

Comment 20

18 years ago
*** This bug has been marked as a duplicate of 6262 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 21

18 years ago
I'm verifying the dyplicate status of this bug.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.