cookies.sqlite written to constantly

RESOLVED DUPLICATE of bug 572223

Status

()

RESOLVED DUPLICATE of bug 572223
9 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tsnap])

(Reporter)

Description

9 years ago
i often keep a view of my profile dir open, sorted by last modified. places.sqlite and sessionstore.js are up there for sure, but cookies.sqlite is definitely the most-often-written-to file in there.

this hurts extremely i/o bound platforms like wince. we should store the data in memory and periodically flush to disk. preferably that period would be a pref.
Component: General → Networking: Cookies
Product: Firefox → Core
QA Contact: general → networking.cookies
(Reporter)

Updated

9 years ago
Keywords: perf
Whiteboard: [tsnap]

Comment 1

9 years ago
We should make use of the asynchronous database stuff here.
Depends on: 449990
Keywords: perf

Comment 2

8 years ago
This is a clone of bug 572223
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 572223
You need to log in before you can comment on or make changes to this bug.