Can't log in on a new account (no pub/privkey to verify)

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Mardak, Assigned: anant)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
verifyPassphrase assumes the user has keys on the server to verify. If the server is empty, it will fail.
(Assignee)

Comment 1

9 years ago
http://hg.mozilla.org/labs/weave/rev/7ceea411fbe1
Assignee: nobody → anant
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

9 years ago
Created attachment 390365 [details] [diff] [review]
changeset 7ceea411fbe1

The let scope in the try catch block won't exist outside of the block. Logging in when the keys exist will now fail.
Attachment #390365 - Flags: review-
(Reporter)

Updated

9 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

9 years ago
Attachment #390365 - Attachment is patch: true
Attachment #390365 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Updated

9 years ago
Keywords: regression
(Assignee)

Comment 3

9 years ago
Bad day for coding :(
http://hg.mozilla.org/labs/weave/rev/914ac9f7acf1
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Blocks: 506147
(Reporter)

Updated

9 years ago
Duplicate of this bug: 443527
You need to log in before you can comment on or make changes to this bug.