Closed Bug 506519 Opened 11 years ago Closed 4 years ago

filtered grouped by sort (e.g. date) shows negative-unread/total message count

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 500610

People

(Reporter: raoul, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2pre) Gecko/20090724 Shredder/3.0b4pre ID:20090724050314

when using a filter via quick search, the unread-counter in the grouped by sort header displays a negative unread counter.

Reproducible: Always

Steps to Reproduce:
1. active grouped by sort via menu: 
1a View | Sort by | Date
1b View | Sort by | Descending
1c View | Sort by | Grouped By Sort
2. use the quick search box to filter for a string - e.g. "zarg"
3. in my example, i now see a collapsed "Last Week (2/2)" Group with two unread emails of 2 total found emails
4. double click the group, it opens the two messages in new tabs
5. switch back to the "Inbox - ..." tab
6. i can now see a "Last Week (-1/2)" Group
7. switch back to the last message (rightmost tab)
8. close both messages using [x] in the right, upper corner of the tab *without* switching back to the "Inbox - ..." tab
9. i can now see a "Last Week (-3/2)" Group
10. expanding the "Last Week (-3/2)" Group, i can see two unread messages
11. clicking the "green dot" to mark the messages as unread, the unread-counter in the "Last Week (-3/2)" group increases to -1: "Last Week (-1/2)"
Actual Results:  
incorrect, negative unread counters

Expected Results:  
correct unread counters that can actually never be negative
Attached image step02 step03
Attached image step04
Attached image step05 step06
Attached image step09 step10
Hi Raoul, 

WFM here on

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090730 Lightning/1.0pre Shredder/3.0b4pre ID:20090730055316

Could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?
does not work on vista business using 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090801 Shredder/3.0b4pre ID:20090801114732

i downloaded this version from the link you provide.
i today tested with 

Mozilla/5.0 (X11; U; Linux i686 (x86_64); de-DE; rv:1.9.1.3pre) Gecko/20090809 Shredder/3.0b4pre

on Ubuntu 8.04.3 LTS (hardy)

i still see the negative message count.

cheers,
raoul
Duplicate of this bug: 610410
Confirming on TB 8.

Testcase with filter resulting in 6 unread messages in group out of 7 shown.
In step 6 I do not get a negative number, but instead an overflowed interger, like 4294967295/7. I am on linux, 32bit.
The count does not change in step 9. However, when marking the 1 read message as unread, the number disappears (as if incremented up to 0) and is shown as (7) instead of (7/7).
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Folder and Message Lists
Ever confirmed: true
OS: Windows Vista → All
QA Contact: front-end → folders-message-lists
Version: unspecified → 3.0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500610
You need to log in before you can comment on or make changes to this bug.