Installed mozilla will NOT launch - hangs

VERIFIED FIXED

Status

SeaMonkey
General
P3
blocker
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Ben Guthrie, Assigned: David Hyatt)

Tracking

({smoketest})

Trunk
x86
Windows NT
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+], URL)

(Reporter)

Description

18 years ago
in reference to:

http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-installer.exe                
29-Aug-2000 06:33   6.6M  

I downloaded , no problem.

executed the installer, no apparent problems.
I chose to delete the previous instalation, custom: no  chatzilla, no mail & 
news

profile manager automatically launched, I chose a profile.

Mozilla hangs on the rectangle window with the fire breathing gecko.

I've killed the process with task manager & tried relaunching the ap, same 
problem.

I rebooted, downloaded a second time, installed again, same results

Updated

18 years ago
Severity: major → critical
Keywords: smoketest

Comment 1

18 years ago
Tinderbox shows no horkage.  Can anyone confirm?

Comment 2

18 years ago
yep.  just hangs there.  Changing the component to Browser-General.
Assignee: ssu → asa
Component: Installer → Browser-General
QA Contact: gemal → doronr

Comment 3

18 years ago
ssu, this is only happening with the installered version of the binary... if you
use a zip file of dist, things work great.

I'll try to compare the directories and see if i can spot glaring ommissions in
jars/dlls
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
*** Bug 50671 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
i bet a chrome file changed and the .mn files are out of date. help me find out
what changed, dprice.
Assignee: asa → dprice

Comment 6

18 years ago
the installer is not generating the all-foo.rdf files or the user-foo.rdf files 
in chrome/ and the installed-chrome.txt is not going away after first 'launch'.  
The zip is working fine, and moving it's .rdf's to the installer's directory 
made the installer work fine.

Comment 7

18 years ago
adding Dan to the CC: list.

Comment 8

18 years ago
installer worked fine on linux build 2000-08-29-08-m18

Comment 9

18 years ago
This also occurs on Commercial Win32 /2000-08-29-08-M18/ build
Whiteboard: [dogfood+]

Updated

18 years ago
Summary: Mozilla will NOT launch - hangs → Application will NOT launch - hangs

Comment 10

18 years ago
installed-chrome.txt isn't there?  That's not right.  Was it there on Monday?  
If it was there on Monday, then I don't think it is the fault of jar packaging. 
 The only changes we made on Monday were to make-jars.pl and correcting some 
jar.mn files.  They don't touch that file.  If it wasn't there on Monday, then 
I'd point the finger of blame at the installer changes that warren did on Friday 
night.  I'm not that familiar with it, but I'm willing to lend a hand.

Comment 11

18 years ago
Sorry, it is there, and is not going away after first launch.  If I understand 
correctly, it should go away, and be replaced with the user-*.rdf and all-*.rdf 
files, which is not happening.
installed-chrome.txt not going away means the failure/hang happens before the 
chrome registry wakes up and does its stuff. This might be very useful in 
narrowing down where the error is. Hyatt: when/where is the chrome registry 
stuff kicked off?

Comment 13

18 years ago
Mark blocker:  per kerz, there is no workaround so we don't have any builds 
after Friday (8/25) that we can test AIM in.
Severity: critical → blocker

Comment 14

18 years ago
installer in summary
Summary: Application will NOT launch - hangs → Installed mozilla will NOT launch - hangs
(Assignee)

Comment 15

18 years ago
Damn. Mine.
Assignee: dprice → hyatt
(Assignee)

Comment 16

18 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
Verified with 082915 on windows.
Status: RESOLVED → VERIFIED

Comment 18

18 years ago
*** Bug 50680 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.