remove support for NS_WIN_JRE_SCAN_KEY

RESOLVED DUPLICATE of bug 583566

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 583566
9 years ago
4 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

Trunk
All
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

8.71 KB, patch
Details | Diff | Splinter Review
(Reporter)

Description

9 years ago
We should stop doing an explicit search for Java plugins in Firefox 4. We would like to treat all NPAPI plugins equally, removing Java as a special case is an important step. The Firefox 4 target allows Java plugin vendors to update their installers.

(Side note: we should also remove special UI for disabling Java and have users simply use the addons manager to disable/enable Java plugins).
(Reporter)

Comment 1

9 years ago
Created attachment 390875 [details] [diff] [review]
fix v1.0
(Reporter)

Comment 2

9 years ago
Java plugin vendors should follow the registry-based solution outlined here:

https://developer.mozilla.org/en/Plugins/The_First_Install_Problem
(Reporter)

Comment 3

8 years ago
Changing summary to reflect a Gecko 1.9.3 target, need Sun to tell us what the first version of Java that will not require us to check Java-specific registry keys is.
Summary: remove support for NS_WIN_JRE_SCAN_KEY in Firefox 4 → remove support for NS_WIN_JRE_SCAN_KEY in Gecko 1.9.3

Comment 4

8 years ago
Sun (became Oracle) has implemented the registry-based solution which is currently scheduled to be in JRE 6 update 21 release.

We'd like to get a Firefox version which implements the registry based solution for testing our fix.
(Reporter)

Comment 5

8 years ago
Created attachment 441529 [details] [diff] [review]
fix v1.1
Attachment #390875 - Attachment is obsolete: true
(Reporter)

Comment 6

8 years ago
We probably shouldn't do this in Gecko 1.9.3. Lets do it in whatever comes after Gecko 1.9.3.
Summary: remove support for NS_WIN_JRE_SCAN_KEY in Gecko 1.9.3 → remove support for NS_WIN_JRE_SCAN_KEY
(Reporter)

Updated

8 years ago
Assignee: joshmoz → nobody
Is this still wanted? The patch has been rotted by http://hg.mozilla.org/mozilla-central/rev/8b86086e5f0e ; would it help if I updated it?
(Reporter)

Comment 8

7 years ago
We want this patch, but not yet. Maybe in six months.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583566
You need to log in before you can comment on or make changes to this bug.