Remove support for plugin.scan.SunJRE

RESOLVED FIXED in mozilla21

Status

()

Core
Plug-ins
P3
minor
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: edggar, Assigned: Cykesiopka)

Tracking

({helpwanted})

1.9.2 Branch
mozilla21
x86
Windows XP
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=bsmedberg][lang=c++][os=windows])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Updating from 1.6.0.20 to 1.6.0.21 the Java plugin now shows up under plugins despite having plugin.scan.SunJRE set to "99.0".

Reproducible: Always

Steps to Reproduce:
1.Set plugin.scan.SunJRE to a high value like 99.0
2.Install Java 1.6.0.21
3.
Actual Results:  
The Java plugin is being listed.

Expected Results:  
Java plugin should not be listed under plugins.

I am seeing the same thing with Thunderbird/3.1.1 Gecko/20100713 but it should affect all builds of Firefox and Thunderbird using said Java version.
Oracle changed the vendor strings with 1.6.0.0.21 from Sun to Oracle

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6969236
(Reporter)

Comment 2

7 years ago
Fixed for me with rv:1.9.2.9 Gecko/20100824 Firefox/3.6.9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
wfm without a patch
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 4

7 years ago
And the problem is back with the latest Java 1.6.0.22
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Should setting plugin.scan.SunJRE to "99.0" through about:config then restarting be enough to reproduce?
If so, I can reproduce with a SeaMonkey 2.10a1(pre) build.
Version: unspecified → 1.9.2 Branch
We should remove support for this preference. All the current+secure versions of Java put their registry keys correctly into HKLM/Software/MozillaPlugins.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Priority: -- → P3
Summary: plugin.scan.SunJRE ineffective with Java 1.6.0.21 → Remove support for plugin.scan.SunJRE
Whiteboard: [mentor=bsmedberg][lang=c++][os=windows]
(Assignee)

Comment 7

4 years ago
Created attachment 714757 [details] [diff] [review]
Remove plugin.scan.SunJRE pref and associated code

Hi, I was familiarising myself with Mercurial and patches, and I thought I would try and fix this bug...

Sorry if the patch doesn't so the correct thing...
Comment on attachment 714757 [details] [diff] [review]
Remove plugin.scan.SunJRE pref and associated code

This look perfect. Normally you'd set the "review" "?" "revieweremail" flag, but since I'm the correct reviewer I'll just mark it. I don't think a try run will test anything useful since we don't have tests for out-of-data Java.

Can you upload a final patch for checkin that includes a slightly better commit message (one mentioning Java at least) and includes "r=bsmedberg". After you've done that, add the 'checkin-needed' keyword to the bug.
Attachment #714757 - Flags: review+
Assignee: nobody → cykesiopka
(Assignee)

Comment 9

4 years ago
Created attachment 714860 [details] [diff] [review]
Remove old Java plugin scanning pref and related code

Updated patch with better commit message
Attachment #714757 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Updated

4 years ago
Attachment #714860 - Flags: review?(benjamin)
Comment on attachment 714860 [details] [diff] [review]
Remove old Java plugin scanning pref and related code

You don't need to request another review on this.
Attachment #714860 - Flags: review?(benjamin)
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb5ab899cfa8
Keywords: checkin-needed
(Assignee)

Comment 12

4 years ago
Ok, sorry about that...
https://hg.mozilla.org/mozilla-central/rev/fb5ab899cfa8
Status: NEW → RESOLVED
Last Resolved: 7 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Comment 14

4 years ago
(In reply to cykesiopka from comment #12)
> Ok, sorry about that...

No need to apologise - just something to know for the future.

Thanks for the patch.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 506719
You need to log in before you can comment on or make changes to this bug.