Closed Bug 50692 Opened 21 years ago Closed 21 years ago

Mozilla doesn't show images gnome_left.jpg and gnome_right.jpg

Categories

(Core :: DOM: HTML Parser, defect, P3)

x86
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 50070

People

(Reporter: linux, Assigned: rickg)

References

()

Details

Since 08/05/00 mozilla doesn't show my homepage correctly (the pics).
Sometimes it even doesn't show the text. Using Netscape 4.7x works with my site!
I tried several versions of mozilla all but all are buggy!
My pages are xhtml compliant and are using a bit css which shouldn't be a
problem for mozilla.
The gnome.htm page has broken source code which fails the w3c check which she
has a button for. Yes, it renders in NN4.75, but view source in this clearly
shows a broken table element (the width attribute doesn't have a closing quote).

The w3c's validator shows rather more problems.

Reporter: can you please fix the problems in the gnome page, run it through a
w3c validator at http://w3.org/ and see if the problem still occurs. Seems the
only sensible course of action for now.

As to the KDE page, the validation still errors, but not as seriously. I'd be
more inclined to think of the KDE page as exposing potential bugs in mozilla
that the GNOME page.

Checked with build 2000082908 Linux.
Reporter emailed in the following:

hi...

these faults on my page didn't affect the main problem!!! I corrected
them...and+mozilla still doesn't show the pics (gnome_left.jpg, gnome_right.jpg,
thekde.gif)!!
Other browser show these pics!!!!!! And I have asked several other people to
look at the html sources! They are correct...
Mozilla doesn't show pics on some other pages...so this is no coincidence!!

you might look closer to the sources...then you see mozilla is BUGGY!
(www.chrisime.de)

Reporter: please add comments to Bugzilla, NOT to people via email.
Marking confirmed, I'm seeing this on build 2000082921 linux. Netscape 4.75
linux on the gnome.htm page displays two images before any text, gnome_left.jpg
and gnome_right.jpg side-by-side. Neither are seen in Mozilla. The KDE page has
one image in the top-left in nn4, mozilla shows nothing. The GNOME page now runs
through the w3c XHTML validator with no errors.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Moving to layout, cc:hixie,jag,self.
Component: Browser-General → Layout
Isn't this a parser bug?  The parser currently handles XHTML 1.0 Transitional
using the Strict DTD, which throws out invalid content which is valid according
to the transitional DTD.

Changing to Parser and reassigning.
Assignee: asa → rickg
Component: Layout → Parser
QA Contact: doronr → janc
If this page is served as text/xml, the it goes through an XML path. As a 
text/html page it *now* goes through the NavDTD (which should get checked in to 
the tree today). Marking as dup.
Status: NEW → ASSIGNED
Marking dupe.

*** This bug has been marked as a duplicate of 50070 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
updated qa contact.
QA Contact: janc → bsharma
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.