Closed Bug 507172 Opened 10 years ago Closed 9 years ago

Intermittent timeout in browser_ui_bookmarks_sidebar.js, browser_ui_history_sidebar.js, browser_ui_history_sidebar_2.js, browser_ui_history_sidebar_3.js | Timed out

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3.7a1

People

(Reporter: mak, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 2 obsolete files)

this could have been caused by test from bug 501413

not completely sure but has started after that push and both are sidebar related, i haven't found a failure before it as of now.
Whiteboard: [orange]
3 of the last 5 Windows unit test runs are orange with this orange.  Can we please either disable this test for now or fix the problem?
Blocks: 438871
we can easily disable this test, but since we still don't know the cause (looks like sidebar stay open in previous tests?) could be that another test will start to fail, and so on...

Actually i cannot reproduce a timeout, but i can reproduce a crash in the test just before that... exactly bug 507219...
sounds a bit crazy, this is probably a crash due to cycle collector, could be on tinderboxes runs just a bit later, dunno. would be interesting to see what happens after fixing the crash
notice i'm also crashing in js while running browser-chrome tests on Windows due to bug 507219. that could also cause some of the timeouts we see (even if i would expect to see a minidump in the log)
in comment 3 i meant bug 506347.
i pushed bug 507219, waiting to see if the timeout was just actually a crash...
this is still failing, and i cannot reproduce the failure in any way, i'm going to disable it for now.
disabled for now
http://hg.mozilla.org/mozilla-central/rev/c99ec9f95c64

i suspect could be due to GC causing some assertion causing a crash on Windows... dunno atm, i have a fix to remove a couple assertions that could happen there, but waiting for tree to reopen.
Do you have any tinderbox output logs from this failure handy?
they don't report anything more than "Timed Out" just after this test starts... if you take any run during 30 or 31 Jul on Windows most of them should have this failure.
Yes, the logs don't shed any light on this...
interesting, now that the above test is disabled, the next one started to fail.
browser_ui_history_sidebar.js

The bug is clearly not in the tests. and this is similar to bug 507199, removing a test moves the crash to the next one... i still suspect a cycle collecting crash.
Duplicate of this bug: 508571
Summary: random failure in browser_ui_bookmarks_sidebar.js → random failure in browser_ui_bookmarks_sidebar.js and browser_ui_history_sidebar.js
could be this was just due to bug 507199. if we don't see further failures, i'd say to re-enable the test (comment 7) and mark as fixed.

Please annotate any failure.
i was able to see this locally one time.

at the end of the run i got this assertion:
###!!! ASSERTION: ScanTXT passed 0 length string: 'inLength', file z:/mozilla-central/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp, line 1373 

this is the stack trace returned: http://mozilla.pastebin.com/m5913ff9f
apart that assertion that could be spurious, i did not notice anything strange... could be the timeout time is just too low for this test?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1253139020.1253148421.30980.gz
WINNT 5.2 mozilla-central unit test on 2009/09/16 15:10:20
Attached patch patch v1.0 (obsolete) — Splinter Review
this should fix all tests, or at least is an experimental fix. Btw it needs bug 516440.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Depends on: 516440
Attached patch patch v1.1 (obsolete) — Splinter Review
test_history_menu is still causing timeouts on mac (and this is somehow expected due to native menus) and a strange failure on a privatebrowsing test.
So it is still disabled.
Attachment #401448 - Attachment is obsolete: true
Attached patch patch v1.2Splinter Review
i'd like to try cleaning up the tests a bit, and reduce repetitions to 6.

If then they will still randomly fail i'll disable and forget'bout'em.
Attachment #402098 - Attachment is obsolete: true
Attachment #405923 - Flags: review?(dietrich)
Comment on attachment 405923 [details] [diff] [review]
patch v1.2

>diff --git a/browser/components/places/tests/perf/browser_ui_history_menu.js b/browser/components/places/tests/perf/browser_ui_history_menu.js

> function test() {
>+  // Skip test on Mac due to native menus.
>+  if (navigator.platform.toLowerCase().indexOf("mac") != -1) {
>+    return;

auto-comment: the above brace is wrong, fixed locally
Comment on attachment 405923 [details] [diff] [review]
patch v1.2

r=me. it's ok to disable these, was just a POC microbenchmark test, doesn't need to be running.
Attachment #405923 - Flags: review?(dietrich) → review+
(In reply to comment #24)
> (From update of attachment 405923 [details] [diff] [review])
> r=me. it's ok to disable these, was just a POC microbenchmark test, doesn't
> need to be running.

yes but if possible it is better to have them running, it's still testing multiple openings of often used ui parts. If not possible we can just disable.
pushed (with fixed brace)
http://hg.mozilla.org/mozilla-central/rev/b6c6c4b45875
Target Milestone: --- → Firefox 3.7a1
so far everything is fine. i'm resolving, please reopen if this happens again.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1255577856.1255580110.9561.gz

happened on WINNT 5.2 mozilla-central test opt everythingelse on 2009/10/14 20:37:36.

> Running chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_bookmarks_sidebar.js...
> TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_bookmarks_sidebar.js | Timed out
> Running chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_menu.js...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
disabled browser_ui_bookmarks_sidebar.js again.
http://hg.mozilla.org/mozilla-central/rev/aa9d34b1ac9a
WINNT 5.2 mozilla-1.9.2 test everythingelse on 2009/11/08 19:37:25
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1257737845.1257739509.20856.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258077163.1258080528.16793.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/12 17:52:43
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258231752.1258234655.16169.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/14 12:49:12
"s: moz2-win32-slave06"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
Depends on: 529860
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258656363.1258662654.27088.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/11/19 10:46:03
"s: moz2-win32-slave41"
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_2.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
Filed Bug 532842 for what appears to be the same orange for browser_ui_history_sidebar_3.js... even if it is the same it will be easier to find. :)
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1261075825.1261078471.15708.gz
WINNT 5.2 mozilla-central opt test everythingelse on 2009/12/17 10:50:25
s: win32-slave12
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_2.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1262308454.1262310395.31660.gz
WINNT 5.2 mozilla-1.9.2 test everythingelse on 2009/12/31 17:14:14
s: win32-slave05
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264024963.1264025678.23947.gz
WINNT 5.2 mozilla-central opt test mochitest-other on 2010/01/20 14:02:43
s: win32-slave17

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_2.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264216360.1264218092.24393.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/01/22 19:12:40
s: win32-slave31
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1264710797.1264713458.29334.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/01/28 12:33:17
s: win32-slave18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265409704.1265410831.32506.gz
WINNT 5.2 mozilla-central opt test mochitest-other on 2010/02/05 14:41:44
s: win32-slave01
PROCESS-CRASH | automation.py | application crashed (minidump found)
Thread 2 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_2.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265406785.1265409432.16762.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/02/05 13:53:05
s: win32-slave13
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_sidebarpanels_click.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_2.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/perf/browser_ui_history_sidebar_3.js | Timed out
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266530758.1266534380.456.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/02/18 14:05:58
s: win32-slave10
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1267052071.1267054940.26626.gz
WINNT 5.2 mozilla-central debug test mochitest-other on 2010/02/24 14:54:31
s: win32-slave26
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1267766600.1267767133.25829.gz
WINNT 5.2 mozilla-1.9.2 test mochitest-other on 2010/03/04 21:23:20
s: win32-slave25
Whiteboard: [orange] → [orange][possibly fixed on trunk]
Assignee: mak77 → nobody
Status: REOPENED → NEW
Summary: random failure in browser_ui_bookmarks_sidebar.js and browser_ui_history_sidebar.js → Random browser_ui_bookmarks_sidebar.js and browser_ui_history_sidebar.js | Timed out
Whiteboard: [orange][possibly fixed on trunk] → [orange]
Summary: Random browser_ui_bookmarks_sidebar.js and browser_ui_history_sidebar.js | Timed out → Intermittent timeout in browser_ui_bookmarks_sidebar.js, browser_ui_history_sidebar.js, browser_ui_history_sidebar_2.js, browser_ui_history_sidebar_3.js | Timed out
Duplicate of this bug: 579538
Duplicate of this bug: 532842
I bumped up the timeout, synced and re-enabled the bookmarks test:

http://hg.mozilla.org/mozilla-central/rev/376390e73d83

I'm leaving open for now though, just in case.
sounds like this is still muted, resolving
Status: NEW → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.