Closed Bug 507203 Opened 12 years ago Closed 12 years ago

Advanced preference pane blank on Windows

Categories

(Thunderbird :: Preferences, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: rsx11m.pub, Assigned: rsx11m.pub)

References

Details

(Keywords: regression)

Attachments

(1 file)

With today's nightly build, Windows NT 5.1 Gecko/20090729 Shredder/3.0b4pre, going into Tools > Options > Advanced presents a blank page and an entry in
the error console "no element found, advanced.xul line 35". Looking into advanced.xul, it appears truncated after the "mail.winsearch.enable" pref.
Attached patch Quick fixSplinter Review
It looks like the fix for bug 506544 lacked an #endif in the #else clause of
the #ifdef XP_WIN part, thus the Display & Reading tab and all following code was included in the #else part and never made it into the Win32 version.

This patch adds the missing #endif back and includes the other tabs again.
Attachment #391412 - Flags: review?(bugzilla)
Blocks: 506544
Assignee: nobody → rsx11m.pub
Target Milestone: --- → Thunderbird 3.0b4
Attachment #391412 - Flags: review?(bugzilla) → review+
Thanks for fixing that.

Checked in: http://hg.mozilla.org/comm-central/rev/47279c0b3403
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.