Closed Bug 507771 Opened 13 years ago Closed 13 years ago

Firefox 2 content shown all the time

Categories

(support.mozilla.org :: Knowledge Base Software, task)

x86
macOS
task
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cilias, Assigned: paulc)

References

()

Details

(Whiteboard: sumo_only)

Attachments

(1 file)

Go to http://support-stage.mozilla.org/en-US/kb/Options+window

The "Feeds panel" section is Firefox 2 only. It should be be displayed when I have 3.0 or 3.5 selected. I noticed this when I saw other Firefox 2 content on other articles, like 

Probably a regression from bug 503146
It appears that showfor simply doesn't work on that page. Not even with firefox3 vs firefox3.5...?

Chris: can you try recreating the page? I have a feeling this is one of those inconsistent bugs. See if you can create more pages like this and every time showfor doesn't work.
Hm. Nevermind. It seems that 3 vs 3.5 works when they are both present. And indeed fx2 content seems to show up all the time. Even on "Clearing private data":
https://support-stage.mozilla.org/en-US/kb/Clearing+private+data
(In reply to comment #0)
> Go to http://support-stage.mozilla.org/en-US/kb/Options+window
> 
> The "Feeds panel" section is Firefox 2 only. It should be be displayed when I
> have 3.0 or 3.5 selected. I noticed this when I saw other Firefox 2 content on
> other articles, like 
> 
> Probably a regression from bug 503146

Firefox 2 has been removed from the list of browsers, so it never gets wrapped in showfor divs. Nothing is telling it it shouldn't be seen anymore.

Simple fix is to add it back into the list of possible browsers, and add it to the ignore content section. That way, it's hidden initially via inline CSS.

I'm not sure of the content policy on SUMO, but if it's not a selector in showfor, the auto-detection shouldn't detect 2 anymore. Or, rather, it shouldn't point to showfor's firefox2. It should point to firefox3 or firefox3.5.

showfor potentially needs rewritten for p10n, but that's still outside the scope of this bug.
Strangely enough, the "Mozilla is not planning any further security and stability updates for Firefox 2" content block is working properly.

If we can keep that working properly, and make article content display the website default (currently 3.5), that would be ideal.
Attached patch patch, v1Splinter Review
Heh. This fix is actually the way I should've done it in the first place. Check it out, Fx2 content seems to be hidden now and all works as before.
Attachment #392520 - Flags: review?(smirkingsisyphus)
Attachment #392520 - Flags: review?(laura)
Comment on attachment 392520 [details] [diff] [review]
patch, v1

Need extra QA for regressions.
Attachment #392520 - Flags: review?(laura) → review+
r48829 / r48830
QA: please see comment 6 :)
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified, FIXED.
Status: RESOLVED → VERIFIED
Attachment #392520 - Flags: review?(smirkingsisyphus)
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.