The default bug view has changed. See this FAQ.

[HTML5]Unclosed <title> eats the page (should be closed by <body>)

RESOLVED WONTFIX

Status

()

Core
HTML: Parser
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: bz, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

See testcase in url field.   This came up on a real web page, but it's an intranet page, sadly (https://intranet.mozilla.org/pto/).

Safari shows the text.  Opera doesn't seem to.  Old Gecko parser shows it.

Note that this is a regression of bug 42945.
Blocks: 373864, 504941
As far as I can tell, this behavior is compatible with IE8 (IE 5.5 mode and IE8 Standars mode tested).

Due to the IE behavior, I doubt this problem is significant on the public Web or on the intranets of companies where IE is used at all.

I'm very tempted to treat this as WONTFIX/INVALID, because closing title on <body> would complicate the tokenizer.

In any case, pursuing this would mean escalating this as a spec bug.
From http://krijnhoetmer.nl/irc-logs/whatwg/20090806#l-513
<hsivonen> I wonder if https://bugzilla.mozilla.org/show_bug.cgi?id=508075  has ever been a practical problem for Opera
<gsnedders|work> hsivonen: Yes
<zcorpan> closing on <body> would be the wrong fix
<zcorpan> the right fix is reparsing
<zcorpan> which is a wontfix :)
<gsnedders|work> hsivonen: (Very very very rare, though)
Yeah, I realize this would need escalation to the spec.  This used to be a serious problem for Gecko (see the number of dups bug 42945 has, if nothing else!).  Did IE change its parsing of <title> at some point or something?
I examined the test cases and live sites from the dupes of bug 42945 in IE6. All live sites were either gone or had been fixed. Most of the time, the test cases caused the whole page to be eaten up in IE6. However, sometimes, the whole page didn't end up being eaten. I couldn't see any logic in eating/not eating the page.

Comment 5

8 years ago
Another page that shows up blank with the HTML5 parser enabled is http://www.sciemetric.com/.  It uses <title content="..." />.
http://www.sciemetric.com/ is blank in IE8 and Opera 10 beta 6477 also. If it is already blank in IE plus another top-4 browser engine, I'd classify it as a site bug.
Considering the behavior of IE8 and Opera 10 in the case of http://www.sciemetric.com/, considering that https://intranet.mozilla.org/pto/ is on a virtually Gecko-only intranet that should be evangelizable and considering the "right" fix would be reparsing, I'm resolving this as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
> that should be evangelizable

It was fixed soon after I filed this bug, fwiw.

Updated

7 years ago
Duplicate of this bug: 592792
You need to log in before you can comment on or make changes to this bug.