Closed Bug 508143 Opened 11 years ago Closed 11 years ago

"Status Bar" and "Sort By" have redundant access keys / mnemonics in View menu

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b4

People

(Reporter: random832, Assigned: mkmelin)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3

Status Bar (showTaskbarCmd in utilityOverlay.dtd) and Sort By (sortMenu in messenger.dtd) both have "S" assigned to their access key though they appear in the same menu.

I have been using the key for Sort By for a long time, so Status Bar is the newcomer. Of letters appearing in the label, "a", "u", and "r" are unused as far as I can tell.

Reproducible: Always

Steps to Reproduce:
1. Alt-V
2. S
3. Various mnemonics assigned to sub-items of sort menu
Actual Results:  
Either nothing at all, or menu item in View menu that matches step 3 is selected.

Expected Results:  
Select a sort option.
WFM here on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3pre) Gecko/20090810 Lightning/1.0pre Shredder/3.0b4pre ID:20090810161308

ALT-V + S highlit only "statusBar" item.

Could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?
I see this with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre) Gecko/20090811 Shredder/3.0b4pre.  Gary, do you see this on non-windows?

  Aureliano, what does your "sort by" map to?

personally i'd like to see status bar move to toolbars menu
Status: UNCONFIRMED → NEW
Component: Toolbars and Tabs → Mail Window Front End
Ever confirmed: true
QA Contact: toolbars-tabs → front-end
(In reply to comment #2)

>   Aureliano, what does your "sort by" map to?

I'm sorry, I'm wrong: ALT-V + S highlit FIRST view--> status bar, but also view-->sort by has "S" key accelerator.
(In reply to comment #2)
> I see this with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3pre)
> Gecko/20090811 Shredder/3.0b4pre.  Gary, do you see this on non-windows?

Macs don't have access keys on menus - only keyboard shortcuts. Haven't yet tested on Linux though.
Attached patch proposed fixSplinter Review
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #394660 - Flags: review?(philringnalda)
Severity: normal → minor
OS: Windows Vista → All
Hardware: x86 → All
Target Milestone: --- → Thunderbird 3.0b4
Comment on attachment 394660 [details] [diff] [review]
proposed fix

just putting my plus on this anyway :)
Attachment #394660 - Flags: ui-review+
Comment on attachment 394660 [details] [diff] [review]
proposed fix

Nice spacing in that file - wonder whether it was chosen with a dartboard, or by cutting a deck of cards...
Attachment #394660 - Flags: review?(philringnalda) → review+
changeset:   3447:784c977804c8
http://hg.mozilla.org/comm-central/rev/784c977804c8

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 530720
You need to log in before you can comment on or make changes to this bug.