Cannot build on Vista x64 with VC9 + MozillaBuild1.4 after bug 505289

RESOLVED FIXED

Status

defect
--
blocker
RESOLVED FIXED
10 years ago
Last year

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({regression})

Trunk
x86_64
Windows Vista
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

After I removed the whitespaces in requestedExecutionLevel, I've never looked the error.
Attachment #392442 - Flags: review?(VYV03354) → review+
Comment on attachment 392442 [details] [diff] [review]
fix

OK, it definitely solved double requestedExecutionLevel problem.
Attachment #392442 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 392442 [details] [diff] [review]
fix

I don't understand why this would fix it, but it looks harmless, and I'll take your and Masatoshi's word for it.
Pushed to mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/285a17333d0b
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
For reference, let me explain what happens here.
MSVC9 linker tries to find requestedExecutionLevel from an existing manifest. If it is not found, the linker will add it.
The linker fails to find an existing requestedExecutionLevel if it contains white spaces. So it will add another requestedExecutionLevel because the linker thinks it is not present yet. Vista/7 consider the manifest is broken and ignore it if it contains duplicate requestedExecutionLevel.
We have two options to deal with the problem:
1. Add /MANIFESTUAC:NO linker flag as bug 419665 did.
2. Remove extra white spaces from requestedExecutionLevel as this bug did.
Thanks for the explanation. This seems like the simplest fix, then.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.