If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Inconsistency in the use of "CC" vs "Cc" and "BCC" vs "Bcc"

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When doing a Search Messages you have the option to search in different fields. 
Here the "CC" and "To or CC" should be changed to "Cc" and "To or Cc".
(Reporter)

Comment 1

17 years ago
Created attachment 13756 [details] [diff] [review]
Fix that changed all references from "CC" to "Cc"
(Reporter)

Updated

17 years ago
Keywords: patch, review

Comment 2

17 years ago
reassign all search/filter UI bugs to gayatrib, part 2
Assignee: alecf → gayatrib
(Reporter)

Comment 3

17 years ago
any chance for a checkin here?
The patch has been laying around since 2000-08-30! Some feedback please...

Comment 4

17 years ago
Well, actually CC is an abbreviation for Carbon Copy. Also, abbrevations are
always written with uppercase. Any objections?
You'll notice in the msgCompose window that we have it labeled as "Cc" 
and "Bcc".  So I think it's fair that this should be changed, too.
QA Contact: lchiang → nbaca
(Reporter)

Updated

17 years ago
Summary: CC should be Cc → Inconsistency in the use of "CC" vs "Cc" and "BCC" vs "Bcc"
(Reporter)

Updated

17 years ago
Keywords: patch, review

Comment 6

17 years ago
r=hwaara

now get someone to sr= this patch...
Keywords: approval, patch
(Assignee)

Comment 7

17 years ago
cc'ing bienvenu to sr= gemal's patch

Comment 8

17 years ago
The lib/libmsg code is dead - there's no reason to check that in.

Also, this change is superfluous since we're already doing a case-insensitive
comparison:
-
	  if (!nsCRT::strncasecmp ("CC", buf, end - buf))
+
	  if (!nsCRT::strncasecmp ("Cc", buf, end - buf))

sr=bienvenu for the rest of the changes.
(Assignee)

Comment 9

17 years ago
David, is it ok if we remove those lib/libmsg files then?  Or just the code 
that gemal patched?

Comment 10

17 years ago
lib/libmsg is not part of SeaMonkey - I don't think it's part of anything (e.g.,
I don't think it ended up part of MozillaClassic either). You should check with
leaf before removing it from the repository.

Comment 11

17 years ago
jglick/german: 4xp is Cc, but CC is an abbreviation, any objections before 
someone commits?
(Assignee)

Comment 12

17 years ago
Don't check this in yet in any case, I'll ask leaf about getting rid of the lib.
(Reporter)

Comment 13

17 years ago
Please help:
Did we agree on "Cc" or "CC"?

Håkan writes: "CC is an abbreviation for Carbon Copy. Also, abbrevations are
always written with uppercase."

I really dont care about what we write, as long as we write the same thing 
everywhere! If CC is correct, I'll provide the patches...
Keywords: approval, patch

Comment 14

17 years ago
`Bcc' and `Cc' are easier to read and distinguish than `BCC' and `CC' are, 
because only the distinguishing letter is capitalized. And acronyms aren't always 
written in upper case, especially when they have been in existence for a while.
(Reporter)

Comment 15

17 years ago
So we all agree on "Cc" and "Bcc" ?

Comment 16

17 years ago
Yes - agreed.

Comment 17

17 years ago
oops, failed to cc german.

we're waiting for comments jglick/german.

Comment 18

17 years ago
"Cc" and "Bcc" are my preference.  

Comment 19

17 years ago
As long as its applied consistently I don't care whether its CC:, cc: or Cc:, 
so yes Cc: and Bcc: and To: would be just fine.
(Assignee)

Comment 20

17 years ago
checked in.

reassigning to me to figure out what to do about libmsg.
Assignee: gayatrib → blakeross

Comment 21

17 years ago
I vote for CC for the reasons Håkan mentioned. "Cc" looks wrong to me - it's no
normal word.
FYI: RFC822 specifies "cc" (but "To"), so that would be fine with me as well.

Comment 22

17 years ago
BTW: I'm not arguing that you should back it out - there are more important
things to work on.
(Assignee)

Comment 23

17 years ago
We can worry about libmsg in a separate bug if anyone's interested.  Closing 
this one.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 24

17 years ago
Build 2001-04-02-04: NT4
Build 2001-04-02-08: Linux RH 6.2, Mac 9.04
Verified Fixed. The Search dialog now shows "To" and "Cc". I also see the same 
format in a new message/compose window.
Status: RESOLVED → VERIFIED

Comment 25

14 years ago
*** Bug 212059 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: nbaca → search
You need to log in before you can comment on or make changes to this bug.