Webclient aborts on Window close event

VERIFIED DUPLICATE of bug 49126

Status

Core Graveyard
Java APIs to WebShell
P3
normal
VERIFIED DUPLICATE of bug 49126
18 years ago
6 years ago

People

(Reporter: geetha.vaidyanaathan, Assigned: edburns)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Running Webclient M4 with Mozilla M16
Click on File --> Close

Get the Following error and Webclient aborts

debug: edburns: ImplObjectNative.delete()
debug: edburns: ImplObjectNative.delete()
closing application

Gdk-ERROR **: BadWindow (invalid Window parameter)
  serial 31602 error_code 3 request_code 4 minor_code 0

aborting...
SIGABRT   6*   abort (generated by abort(3) routine)
    si_signo [6]: SIGABRT   6*   abort (generated by abort(3) routine)
    si_errno [0]: Error 0
    si_code [-1]: SI_LWP [pid: 2832, uid: 35239]
	stackpointer=fe7040f4

Full thread dump Classic VM (JDK-1.2.2-W, native threads):
    "Thread-0" (TID:0xfacbd3c0, sys_thread_t:0x2f668, state:CW, native ID:0x1)
prio=5
    "Screen Updater" (TID:0xfacc5d78, sys_thread_t:0x4d34d8, state:CW, native
ID:0xc) prio=4
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java, Compiled Code)
	at sun.awt.ScreenUpdater.nextEntry(ScreenUpdater.java, Compiled Code)
	at sun.awt.ScreenUpdater.run(ScreenUpdater.java, Compiled Code)
    "EventThread-4404432" (TID:0xfacc4910, sys_thread_t:0x437228, state:R,
native ID:0xa) prio=5
	at
org.mozilla.webclient.wrapper_native.NativeEventThread.run(NativeEventThread.java,
Compiled Code)
    "AWT-Motif" (TID:0xfaca0e08, sys_thread_t:0x38e880, state:R, native ID:0x9)
prio=5
	at sun.awt.motif.MToolkit.run(Native Method)
	at java.lang.Thread.run(Thread.java, Compiled Code)
    "SunToolkit.PostEventQueue-0" (TID:0xfaca1260, sys_thread_t:0x367890,
state:CW, native ID:0x8) prio=5
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Object.java, Compiled Code)
(Reporter)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 49126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
Component: Java APIs to WebShell → Java APIs to WebShell
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.