Closed Bug 508561 Opened 11 years ago Closed 4 years ago

SVGUseElement has no instanceRoot attribute (SVG DOM)

Categories

(Core :: SVG, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tangui.lepense, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)

The SVGUseElement have no instanceRoot attribute in the SVG DOM, which makes impossible to access the shadow tree of a use element.

Reproducible: Always

Actual Results:  
This property isn't implemented

Expected Results:  
The shadow tree should be accessible
Click on the green square
Pretty much the same as bubg 265895 although this is a better testcase as that bug does not seem to have a testcase that has anything to do with the bubg as far as I can tell.
Duplicate of this bug: 589647
Blocks: ietestcenter
Status: UNCONFIRMED → NEW
Depends on: 265895
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
SVGElementInstance trees have been removed from SVG 2, so we won't be doing this.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.