Last Comment Bug 508684 - Add Ability to Change "Firefox as your default browser" and inform of upgrade on Summary step
: Add Ability to Change "Firefox as your default browser" and inform of upgrade...
Status: RESOLVED FIXED
: verified1.9.2
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: unspecified
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
: 511470 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-05 14:41 PDT by ken kovash
Modified: 2009-09-17 16:33 PDT (History)
15 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta1-fixed
.4-fixed


Attachments
Summary page screenshots (doesn't include upgrade button) (184.84 KB, image/png)
2009-08-31 21:23 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
faaborg: ui‑review+
Details
patch for 1.9.2 and trunk (10.04 KB, patch)
2009-09-01 11:42 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
jmathies: review+
Details | Diff | Review
1.9.1 patch - no l10n impact (6.79 KB, patch)
2009-09-01 11:51 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
jmathies: review+
dveditz: approval1.9.1.4+
Details | Diff | Review
updated patch (8.13 KB, patch)
2009-09-01 19:23 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
robert.strong.bugs: review+
mbeltzner: approval1.9.2+
Details | Diff | Review
as checked in (11.08 KB, patch)
2009-09-04 12:47 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
robert.strong.bugs: review+
Details | Diff | Review

Description ken kovash 2009-08-05 14:41:37 PDT
For the Windows installer, on the "Summary" step, where we say, "Firefox will be set as your default browser", we should add an option for users to modify this setting (e.g., by instructing them to hit the back button, or by adding a "change" button).

Discussion on this request can be found here: http://blog.mozilla.com/metrics/2009/08/03/more-changes-coming-to-the-firefox-installer/.
Comment 1 Alex Faaborg [:faaborg] (Firefox UX) 2009-08-06 18:55:50 PDT
Some options include:

1) only mention being default once (so they aren't confused by a combination of first a question and then a statement)

2) ask as a question in both locations using a checkbox

3) defer the default question to after the first run experience.  The user will have more information to make an informed decision at that point anyway, but the downside is that the dialog gets in their way as they are leaving the application

Overall we shouldn't give them instructions to change the setting when we could just give them the setting itself.  So for instance I prefer option 2 compared to a sentence instructing them to go back.

These choices of course all have huge implications for retention and ethical considerations (express setup, etc.)
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-19 11:50:14 PDT
*** Bug 511470 has been marked as a duplicate of this bug. ***
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-28 10:13:05 PDT
To fix this we're going to move the "Use Firefox as my default web browser" checkbox to the summary page and change the button text from Install to Upgrade. Though we could provide info regarding the version they are upgrading from / to it seems that for the majority of users this would just be extraneous info the user would at best ignore and at worst would have to parse.
Comment 4 Alex Faaborg [:faaborg] (Firefox UX) 2009-08-28 20:40:40 PDT
I'm going to file a follow up bug to attempt reduce the overall number of steps in the install process wizard.
Comment 5 Alex Faaborg [:faaborg] (Firefox UX) 2009-08-28 21:15:41 PDT
Filed follow up bug 513414 to see if we can streamline the install.
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-31 21:23:00 PDT
Created attachment 397802 [details]
Summary page screenshots (doesn't include upgrade button)

This shows the four states of the UI without the two additional states for the next button (e.g. Install or Upgrade and already verbally reviewed by beltzner).

screenshot 1 - can set as default and a reboot may be required
screenshot 2 - can set as default and no reboot required
screenshot 3 - can't set as default (e.g. no permissions to set required registry keys or already default) and a reboot may be required
screenshot 4 - can't set as default (e.g. no permissions to set required registry keys or already default) and no reboot required

Alex, I reused the existing strings but perhaps they could be better... can I get a string review from you?
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-01 11:42:56 PDT
Created attachment 397914 [details] [diff] [review]
patch for 1.9.2 and trunk
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-01 11:51:00 PDT
Created attachment 397916 [details] [diff] [review]
1.9.1 patch - no l10n impact
Comment 9 Jim Mathies [:jimm] 2009-09-01 13:28:07 PDT
(In reply to comment #7)
> Created an attachment (id=397914) [details]
> patch for 1.9.2 and trunk

Does write access to HKLM tie directly to our ability to register (even under HKCU) as the default browser?

+    ; Check is Firefox is already the handle

One minor comment nit - "is" -> "if"
Comment 10 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-01 13:46:54 PDT
(In reply to comment #9)
> (In reply to comment #7)
> > Created an attachment (id=397914) [details] [details]
> > patch for 1.9.2 and trunk
> 
> Does write access to HKLM tie directly to our ability to register (even under
> HKCU) as the default browser?
Though we can set the handler keys via HKCU write access to HKLM is necessary for setting as the StartMenuInternet client and I would prefer just letting the app set this via helper.exe when in this is the case. BTW: on Vista and above we try to elevate when setting as default from the app.

Fixed the typo
Comment 11 Jim Mathies [:jimm] 2009-09-01 13:57:41 PDT
Comment on attachment 397914 [details] [diff] [review]
patch for 1.9.2 and trunk

WFM
Comment 12 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-01 19:23:35 PDT
Created attachment 398065 [details] [diff] [review]
updated patch

carrying forward review. Fixed typo, added localization note, and changed UpgradeBtn to UPGRADE_BUTTON to be consistent in custom.properties
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-01 21:08:38 PDT
Comment on attachment 397802 [details]
Summary page screenshots (doesn't include upgrade button)

Alex, besides strings if you could also provide input as to control placement it would be appreciated. It might make more sense to put the only question on this page as the first item for example.
Comment 14 Alex Faaborg [:faaborg] (Firefox UX) 2009-09-03 15:51:21 PDT
Comment on attachment 397802 [details]
Summary page screenshots (doesn't include upgrade button)

looks good, perhaps Web should be capitalized since it is a proper noun? (we aren't totally consistent about that in the product).
Comment 15 Mike Beltzner [:beltzner, not reading bugmail] 2009-09-04 12:26:38 PDT
Comment on attachment 398065 [details] [diff] [review]
updated patch

a192=beltzner
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-04 12:45:56 PDT
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/131543cad782
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-04 12:47:49 PDT
Created attachment 398742 [details] [diff] [review]
as checked in

Added one comment fix
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-04 12:49:59 PDT
Pushed to mozilla-1.9.2
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/b07689c3cfbd
Comment 19 Marcia Knous [:marcia - use ni] 2009-09-08 12:43:04 PDT
Verified fixed on the 1.9.2 branch using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a2pre) Gecko/20090908 Namoroka/3.6a2pre (.NET CLR 3.5.30729). I verified the fix by performing a new install of Namoroka and verifying that the checkbox is on the summary page as well as verifying the upgrade verbiage performing an install after FF is already installed.
Comment 20 Samuel Sidler (old account; do not CC) 2009-09-11 11:25:26 PDT
Comment on attachment 397916 [details] [diff] [review]
1.9.1 patch - no l10n impact

1.9.1.4 won't ship until until mid-late October. 1.9.2 will ship shortly after (November). We can just pick this up in 1.9.2. If I'm missing the severity of this, feel free to renominate for approval with full rationale.
Comment 21 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-11 11:34:06 PDT
Comment on attachment 397916 [details] [diff] [review]
1.9.1 patch - no l10n impact

Well, this fixes one of the problems discovered by the install survey and getting it in earlier than later will allow us to tune 1.9.2 based on user feedback if necessary. The patch on trunk / 1.9.2 has baked for a while now without regressions and the patch for 1.9.1 is just a subset of the trunk / 1.9.2 patch. I'd really like to get this landed otherwise we'll have to wait months before taking additional steps to improve the install process.
Comment 22 ken kovash 2009-09-11 11:57:46 PDT
The current installer UI ("Use Firefox as my default browser") is turning away IE users who want to download/install Firefox for the first time.  This seems like a change we'd want to get in (and measure its actual impact) ASAP.
Comment 23 Michael Ryan 2009-09-12 10:21:56 PDT
I find this change to be a little confusing. When I'm installing something, I don't expect the "summary" dialog to have more options that I haven't seen before. There should always be at least one dialog with no options in case the user accidentally double-clicks "Next ->".
Comment 24 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-14 12:14:35 PDT
Though I agree with the summary page having options (will be fixed in bug 513414) having a summary step doesn't fix the double click problem in the case where the next step is the summary step and with a wizard which should replace next with install per MS wizard design.
Comment 25 Daniel Veditz [:dveditz] 2009-09-14 15:26:59 PDT
Comment on attachment 397916 [details] [diff] [review]
1.9.1 patch - no l10n impact

Approved for 1.9.1.4, a=dveditz
Comment 26 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-17 16:33:48 PDT
Pushed to mozilla-1.9.1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/a66a244b5173

this only fixes the "Add Ability to Change 'Firefox as your default browser' on Summary step" on 1.9.1 so it wouldn't affect l10n

also made one comment typo fix in the checkin

Note You need to log in before you can comment on or make changes to this bug.