Sisyphus - support parallel builds and caching of mozilla-build's environment

RESOLVED DUPLICATE of bug 715980

Status

RESOLVED DUPLICATE of bug 715980
10 years ago
7 years ago

People

(Reporter: bc, Assigned: bc)

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

10 years ago
bug 509164 adds support for reading environment variables from mozilla-build's start-*.bat files but uses a fixed file name in the user's profile for recording the values. This prevents simultaneous builds as well as disallows caching of the results.

The lack of parallelism blocks running multiple sisyphus runs simultaneously for the automated crash testing.
Flags: in-testsuite-
(Assignee)

Updated

10 years ago
Summary: Sisyphus - support parallel builds an caching of mozilla-build's environment → Sisyphus - support parallel builds and caching of mozilla-build's environment
(Assignee)

Updated

9 years ago
Blocks: 548019
(Assignee)

Comment 1

7 years ago
this was handled in bug 715980
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715980
You need to log in before you can comment on or make changes to this bug.