Closed Bug 509338 Opened 11 years ago Closed 10 years ago

Shortcut Ctrl+K missing

Categories

(SeaMonkey :: Help Documentation, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0

People

(Reporter: Hb, Assigned: InvisibleSmiley)

References

Details

(Keywords: fixed-seamonkey2.0)

Attachments

(1 file, 3 obsolete files)

In Mail & News summary view the keyboard shortcut Accelerator + K (Ctrl+K on Windows) sets the focus into the Search Subject and From text field. This shortcut is missing in | Help and Support Center | Seamonkey Keyboard Shortcuts | Mail & Newsgroups Shortcuts |.

Address Book has the same shortcut for Search Name and Email field. A hint to this shortcut in | Searching Address Books and Directories | would be fine.

Bug 460694 dealt with the shortcuts themselfs.
Since accel+F and accel+F focus (almost) all our search fields, we should probably have them listed under "General shortcuts".
(In reply to comment #1)
> Since accel+F and accel+F

"accel+F and accel+K" ...
Blocks: 423281
Attached patch proposed patch (obsolete) — Splinter Review
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #395172 - Flags: review?(stefanh)
Comment on attachment 395172 [details] [diff] [review]
proposed patch

>+    <td>Ctrl+F or Ctrl+K</td>

In split message view both shortcuts work. Ctrl+F gives "Find in this page" and Ctrl+K sets the focus to "Search Subject and From". Does the word "or" reflect this?
"Find" is not really the same as focusing a search field.
"Focus Search Field", then?

Possible placements:
- before Find
- behind Find Again
- behind Find Text As You Type
- somewhere completely different
Attached patch alternate approach (obsolete) — Splinter Review
"Quicksearch" better reflects what Ctrl+K focuses (in MailNews, Address Book and Help) and is less likely to be confused with the search field within the Find In This Page dialog.

Regarding placement I chose above Find because Quicksearch and Find are more related than the other items. By that logic, placing it below would also be possible. You choose.
Attachment #395172 - Attachment is obsolete: true
Attachment #398984 - Flags: review?(stefanh)
Attachment #395172 - Flags: review?(stefanh)
Last time I checked it was either accel+F or accel+K. See for example the applications pref panel.
(In reply to comment #8)
> Last time I checked it was either accel+F or accel+K. See for example the
> applications pref panel.

I think we should change the binding there then for consistency. Do you have more examples?
Hmm, after some investigation it seems like Accel+F is used in most places (Bookmarks, History, Cookie Manager, Password Manager, Download Manager), deliberately chosen in bug 460694. I think this is bad from a consistency point of view but I don't like Accel+K too much either so I won't make an attempt to change it. I'll attach a patch with both shortcuts later today, listing Accel+F first since it's used in more places.
Yeah, I was just going to point you to that bug. It's true that having Accel+k for everything might have been better in respect to this bug, but I guess most people like the current connection to "Search" (either bring up the find dialog or focus a search field)
(In reply to comment #11)
> ..., but I guess most people like the current connection to "Search" 
> (either bring up the find dialog or focus a search field)

Current situation is mismatched.

I'd like Accel+F to *F*ind something within the content of a single item (web page, mail et. al.) and Accel+K to search a specifi*K* item out of a list of items (history, inbox, passwort, cookie).
Attached patch patch v3 (obsolete) — Splinter Review
Attachment #398984 - Attachment is obsolete: true
Attachment #399074 - Flags: review?(stefanh)
Attachment #398984 - Flags: review?(stefanh)
Attached patch patch v4Splinter Review
Yet another way...
Attachment #399074 - Attachment is obsolete: true
Attachment #399097 - Flags: review?(stefanh)
Attachment #399074 - Flags: review?(stefanh)
Attachment #399097 - Flags: review?(stefanh)
Attachment #399097 - Flags: review+
Attachment #399097 - Flags: approval-seamonkey2.0?
Comment on attachment 399097 [details] [diff] [review]
patch v4

No risk, help update.
(In reply to comment #12)
> I'd like Accel+F to *F*ind something within the content of a single item (web
> page, mail et. al.) and Accel+K to search a specifi*K* item out of a list of
> items (history, inbox, passwort, cookie).

KaiRo just confirmed on IRC that the basic idea is to have the main (as in "featured", not "full featured") search functionality accessible through Ctrl+F, i.e. in most cases focusing the search field. The Find dialog is really an exception, and where it is bound to Ctrl+F and another search functionality is available (MailNews, Help), the latter is accessible through Ctrl+K. The only place I know where that rule doesn't fit is the Address Book where Ctrl+F does nothing (on purpose? I don't know) but that may be because it's shared code.

If you feel anything of the above should be changed, please file a new bug on that, this one is about Help and about to be closed.
(In reply to comment #16)
> The
> only place I know where that rule doesn't fit is the Address Book where Ctrl+F
> does nothing (on purpose? I don't know) but that may be because it's shared
> code.

It's not, filed bug 515081.
Attachment #399097 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/c5cbed0e0a3d
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0
Adding fixed-seamonkey2.0 keyword so the queries for approved but not fixed bugs don't catch that bug.
You need to log in before you can comment on or make changes to this bug.