If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Personas for RTL languages such as Arabic

RESOLVED WONTFIX

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED WONTFIX
8 years ago
a year ago

People

(Reporter: Djihed Afifi, Assigned: Chris Beard)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.11) Gecko/2009060308 Ubuntu/9.04 (jaunty) Firefox/3.0.11
Build Identifier: Personas 1.2.2

In an Arabic Firefox, the interface is RTL rather than LTR. This means that personas that were developed with an LTR interface in mind look rather odd in Arabic.

This is because most Personas use the space that is not cluttered with buttons (the right side) to show a prominent feature of the theme, such as the decoration in the default blue persona, or the moon.

Thus, for RTL languages these images should be reversed to look stylistic as intended.

For an implementation, I suggest that all personas on the website should have both an LTR and an inverted RTL image. Creating the RTL image should be straightforward with ImageMagick tools.

The client can then choose to get the right image based on the interface direction.

This also applies to other RTL languages I imagine.

Reproducible: Always

Steps to Reproduce:
1. Use Arabic Firefox with Arabic installation.
2. Notice the inverted interface. Install Personas.
3. Enable a persona that shows a feature on the right side.

Actual Results:  
The feature is hidden behind the buttons in the RTL interface.

Expected Results:  
Inverted image.

Updated

8 years ago
Blocks: 511104
While this seems like a good, simple idea initially, there are many personas with text and/or designs that would look weird if mirrored.
There might also be some legal/trademark implications of flipping a logo or another design. 

We should, however, try to cater to the needs of our RTL users, for example by allowing and encouraging personas authors to post an RTL version of their design (and if the design allows it, they would simply filip it horizontally and submit as such).
wontfixing, the issue of flipping persona images should be handled by Firefox. If this is still an issue please open a bug under Firefox -> Theme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

8 years ago
Refiled under bug #543443
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.