Closed Bug 511104 Opened 11 years ago Closed Last year

[meta] Lightweight themes support tracking bug

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dao, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: meta, user-doc-complete)

This bug is going to track the tasks that need to be tackled in order to get support for lightweight themes (aka personas) built into Firefox.
Depends on: 511107
Depends on: 511108
Depends on: 511771
Depends on: 509415
Depends on: 516013
Depends on: 517490
Depends on: 518120
No longer depends on: 518120
Depends on: 518806
Depends on: 518859
Depends on: 519486
Depends on: 520124
Depends on: 520346
Depends on: 521076
Blocks: 521363
No longer blocks: 521363
Depends on: 521363
Depends on: 520644
Depends on: 522188
Depends on: 522513
No longer blocks: 522571
Depends on: 522571
Depends on: 520173
Depends on: 525651
No longer blocks: 525917
Depends on: 525917
Depends on: 526919
Depends on: 527463
Depends on: 527544
No longer depends on: 527544
Depends on: 529729
No longer depends on: 529729
(In reply to comment #1)
> user-doc-complete
> https://support.mozilla.com/en-US/kb/Using+themes+with+Firefox

That article suggests you need to install the Personas add-on, which is wrong. 3.6 has native support (which this bug tracks), which means you just need to go to a site that offers such themes, like <https://addons.mozilla.org/firefox/personas/>.
Depends on: 529769
We have to provide support for 3.5 users as well, which is why the article says:
"First, install the Personas extension (Personas is built in to Firefox 3.6, so if you are using Firefox 3.6, skip to the Once Personas is installed section.)"
Is there a good reason why the very same page is served regardless of the Firefox version?
Many users don't know which version of Firefox they are using. And that number will grow if 3.6 gets delivered as a minor update.
Usually different content is shown depending on the major version (3.0 vs. 3.5). If you look at the top of the article, to the right of the article title, there is a selector called "Show content customized for:". Version and OS are detected automatically. 3.5 and 3.6 are classified the same because we were told that 3.6 was a minor update to 3.5 and 3.5.x would be discontinued after the release of 3.6. I know that is still up in the air, which is I asked in dev.planning. 
<http://groups.google.com/group/mozilla.dev.planning/browse_frm/thread/6c8f06fbdf745d72>
I don't think SUMO needs to treat them the same even if 3.6 is going to be a minor update.
Yeah, I agree. Unfortunately, it's too late to go back on that decision for 3.6 (bug 521109).
Depends on: 532015
Depends on: 530103

Personas were in Firefox and then removed, so I believe this should have been closed long ago.

Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Summary: Lightweight themes support tracking bug → [meta] Lightweight themes support tracking bug

(In reply to Mark Banner (:standard8) from comment #8)

Personas were in Firefox and then removed, so I believe this should have been closed long ago.

Personas were renamed to lightweight themes, and the webextension theme API is based on this. Basically you just closed a bunch of year-old bugs that may very well still be valid. Can you please revert this?

Status: RESOLVED → REOPENED
Flags: needinfo?(standard8)
Resolution: FIXED → ---

Oh, this meta bug has indeed outlived its purpose and can remain closed.

Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED

(In reply to Dão Gottwald [::dao] from comment #9)

(In reply to Mark Banner (:standard8) from comment #8)

Personas were in Firefox and then removed, so I believe this should have been closed long ago.

Personas were renamed to lightweight themes, and the webextension theme API is based on this. Basically you just closed a bunch of year-old bugs that may very well still be valid. Can you please revert this?

I discussed this with Dão offline, and as a result we have re-opened a few after rechecking them all. Sorry for the noise and my apologies to Dão for not discussing with him first.

Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.