Last Comment Bug 509710 - qcms doesn't support profiles without tone reproduction curves
: qcms doesn't support profiles without tone reproduction curves
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: GFX: Color Management (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal with 5 votes (vote)
: ---
Assigned To: Benoit Girard (:BenWa)
:
: Milan Sreckovic [:milan]
Mentors:
: 520957 (view as bug list)
Depends on: 679875
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-11 08:04 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-09-25 04:33 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
An example profile from http://www.getcolormanaged.com/images/090721_LaCie_LUT.icc) (236.08 KB, application/octet-stream)
2009-08-11 08:09 PDT, Jeff Muizelaar [:jrmuizel]
no flags Details
Argyll CMS XYZ LUT (1.01 MB, application/octet-stream)
2009-12-20 17:34 PST, Alex Firestone
no flags Details

Description Jeff Muizelaar [:jrmuizel] 2009-08-11 08:04:56 PDT
Some profiles don't have tone reproduction curves, we should ideally still support them.
Comment 1 Jeff Muizelaar [:jrmuizel] 2009-08-11 08:09:28 PDT
Created attachment 393767 [details]
An example profile from http://www.getcolormanaged.com/images/090721_LaCie_LUT.icc)
Comment 2 Petr Holub 2009-09-11 01:39:10 PDT
May be related to bug #463221.
Comment 3 Jeff Muizelaar [:jrmuizel] 2009-10-03 10:14:52 PDT
This is also needed to support the iccv4 example profiles on http://www.color.org/version4html.xalter
Comment 4 Jeff Muizelaar [:jrmuizel] 2009-10-07 17:40:02 PDT
*** Bug 520957 has been marked as a duplicate of this bug. ***
Comment 5 Alex Firestone 2009-12-20 17:34:41 PST
Created attachment 418581 [details]
Argyll CMS XYZ LUT

Valid Argyll CMS XYZ-LUT profile without rXYZ, bXYZ, gXYZ, rTRC, bTRC, and gTRC tags that doesn't work with Firefox 3.5.x on Windows XP.
Comment 6 Alex Firestone 2009-12-20 17:45:52 PST
For the previous attachment, I'm unsure if this means qcms doesn't support XYZ-LUT profiles, since according to the developer of Argyll CMS, the rXYZ, bXYZ, gXYZ, rTRC, bTRC, and gTRC are matrix specific profile tags and have nothing to do with the functionality of LUT profiles.

Most profiling applications add the matrix profiles tags to their LUT profiles as a fall back, leaving it up to the application to choose which to use. So while it may have been originally thought that qcms worked with LUT profiles, maybe it really was only using those fall-back matrix profile tags within the LUT profiles.

In other words, since qcms won't work without matrix profile specific tags preset, maybe it doesn't support LUT profiles at all?

If this is the case, maybe another bug needs to be opened to add support for XYZ LUT profiles in qcms?
Comment 7 Alex Firestone 2010-01-06 02:31:54 PST
I've confirmed that indeed qcms doesn't support LUT profiles (both LAB and XYZ).

Since the core issue is more accurately the lack of support of LUT profiles, rather then the lack of support of profiles without tone reproduction curves, I've opened a new bug here: https://bugzilla.mozilla.org/show_bug.cgi?id=538114
Comment 8 Benoit Girard (:BenWa) 2012-09-25 04:33:53 PDT
This feature was added to qcms but requires the v4 feature to be enabled. Closing as fixed but this will require bug 679875 to be on by default.

Note You need to log in before you can comment on or make changes to this bug.