Status

P1
critical
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: mikepinkerton, Assigned: slamm)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

Attachments

(5 attachments)

- launch mozilla
- open sidebar (or have it open when app launches, doesn't matter)

expected:
- see sidebar panels

actual:
- no sidebar panels at all. area is blank except for "My Sidebar" header

both mac/win32 builds from 11am 8/31/00
this is kinda bad, i think.
Keywords: correctness, nsbeta3, regression
broken in all skins.
(Assignee)

Comment 3

19 years ago
Yeah, this seems pretty bad. 

Mike, would you attach you panels.rdf and localstore.rdf from you profile 
directory?
i deleted my panels.rdf to see if that would help and it never came back. that 
seems like a possible problem. i guess this profile is now just hosed. i'll try 
attaching my panels.rdf from my windoze box
Created attachment 13842 [details]
panels.rdf file
Created attachment 13843 [details]
localstore.rdf
(Assignee)

Comment 7

19 years ago
Did deleting your profile bring back the sidebar?
yes, deleting my profile brought back the sidebar.

Comment 9

19 years ago
This has been around for at least the last 3 or 4 days on Linux.  When I first
noticed this bug, I also noticed the following error message:

JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult:
"0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://communicator/content/sidebar/sidebarOverlay.js :: sidebar_overlay_init
:: line 503"  data: no]
ok, with my new profile, i surfed around for a while, played with the sidebar, 
closed it, surfed some more, etc...then went to check tinderbox so I opened up 
the sidebar again and...

the tinderbox panel was blank. I switched to bookmarks...also blank! All the 
panels are blank now.

Comment 11

19 years ago
*** Bug 51060 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
*** Bug 51223 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
*** Bug 51271 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
I can bring some precisions (I've reported the bug 51271 marked as dup and I
finaly understood what happens):

1) launch mozilla
2) if sidebar is open (all is right, panels are visible), close it
3) push CTRL+N (open a new window)
   -> sidebar of the new window is closed (as it should be).
4) open the sidebar
   -> expected: panels are visible
   -> actual: only panels title are visible, there's no content in panels
5) push CTRL+N (open a new window)
   -> sidebar of the last window is open (as it should be) and panels are
visible (unlike 4)!!!
6) close the sidebar of the last window
7) goto 3)

and it continues (panels are right in 5, panels are empty in 4)...


I think that we can insert "close mozilla, open mozilla" after any of those
points because the state of sidebar is remembered.

=>> If a browser window is open, where the last remembered state of the sidebar
is "open", the sidebar is right, but if the last state is "closed", when we open
it, panels are empty!

(My Mozilla is build 2000090321 for linux).

(I hope I have been clear, excuse me for my bad English!)

Comment 15

19 years ago
*** Bug 51284 has been marked as a duplicate of this bug. ***

Comment 16

19 years ago
For reasons unknown, I see the sidebar functioning properly on all my builds 
(2000090508m18). I launch fine with both skins and still see no problems. 

Comment 17

19 years ago
still doesn't work for me on Linux 2000090508.

Comment 18

19 years ago
Nav triage team: [nsbeta3+]; this is really bad.
Priority: P3 → P1

Comment 19

19 years ago
I can repo this using the instructions from Laurent RINEAU on 2000-09-04 04:36.
Running 2000090508 on win98.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 20

19 years ago
I have a fix I hope to check in today.

Comment 21

19 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]

Comment 22

19 years ago
*** Bug 51749 has been marked as a duplicate of this bug. ***

Comment 23

19 years ago
I am seeing this bug as well, on 2000090704 on Windows NT, and on the
latest builds I've been trying on Linux.  All I see is the
sidebar and the My Sidebar header.  If I customize the bar to add or remove
items, no good, nothing happens.  If I open up the JavaScript console and
attempt to show or hide the sidebar, or add or remove items from the sidebar
using the sidebar customization, no messages appear in the console at all.

This state of affairs has been present for the last week or so, under all
skins, etc.

I realize that I'm not adding anything to the discussion here, as it sounds like
you're at the point of being able to replicate this bug, but I'll keep checking
the nightly builds on my WinNT box and Linux box fwiw.
(Assignee)

Comment 24

19 years ago
I checked in a fix. 
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 25

19 years ago
Thank you for the fix. All is right now with build 2000090721 on linux.

Comment 26

19 years ago
*** Bug 51838 has been marked as a duplicate of this bug. ***

Comment 27

19 years ago
This is not fixed for me in 2000090808 NT.. I still have no tabs at all in my
sidebar, even if I use the customize sidebar menu to add or remove tab definitions.

(Assignee)

Comment 28

19 years ago
Jonathan, would you attach your localstore.rdf and panels.rdf files from your 
profile? That will help me track it down.

T

Comment 29

19 years ago
Yes, I'll get those to you Monday when I get back in to work.

Comment 30

19 years ago
linux 2000090906 - clean install, fresh profile, new RH glibc 2.1.3-21

Sidebar initially displayed but after unchecking it in view/sidebar and later
restarting moz, it was again empty in the browser. It displays ok when turned
on/off in mailnews however.

Comment 31

19 years ago
I was one of those duplicate reports on the list.  On build 2000090908 for Win
NT everything appears to be working perfectly.  I ran through the same process
that R.K.Aa did for Linux, and was unable to produce a failure on NT.  I have
not wiped clean my profile from before the problem showed up until present.  In
short, everything looks about perfect on NT without doing anything special.

Comment 32

19 years ago
Created attachment 14399 [details]
Broken sidebars, 2000090808 NT

Comment 33

19 years ago
Created attachment 14400 [details]
panels.rdf, broken sidebar 2000090808 NT

Comment 34

19 years ago
Okay, I've added attachments for my localstore.rdf (labeled 'Broken sidebars,
2000090808 NT') and my panels.rdf ('panels.rdf, broken sidebar 2000090808 NT').

As per my comments, I still get no sidebar tabs in the sidebar.
(Assignee)

Comment 35

19 years ago
You attached panels.rdf twice. I will try it out, but looks ok. Would your try 
another time to attach your localstore.rdf?
(Assignee)

Comment 36

19 years ago
I checked in some more changes to handle the case of pinkertons's 
localstore.rdf. Jonathan, there is a chance that you are running into the same 
problem. If you see that sidebar-panels has a hidden attribute set to true, then 
it is the same problem.

Comment 37

19 years ago
Created attachment 14458 [details]
localstore.rdf, still no sidebars in 2000091108 NT

Comment 38

19 years ago
Okay, I've posted my localstore.rdf, still no sidebars in 2000091108 NT.

Comment 39

19 years ago
forgot to reopen this...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 40

19 years ago
I checked in changes for Jonathan's case on 9/11, so I would expect the 9/11 
build to still be broken. The panels should appear in a more recent build. 
Marking fixed again.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 41

19 years ago
I was unable to repro this bug using today's builds(09/14). Jonathan, could you 
see if this is fixed for you too? Marking VERIFIED. Pls reopen if this problem 
still persists.
Status: RESOLVED → VERIFIED

Comment 42

19 years ago
Yup, I confirm it as fixed on Linux and NT.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.