If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

various preferences panels do not default to current value

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
P3
normal
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Moses Lei, Assigned: matt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Various selection lists in Edit\Preferences should initialize with the current 
value selected (to show the current value), but instead initialize with the 
first item in the list selected. A few examples:

1) Appearance\Themes. I am using the Classic skin, but when I open this 
preferences panel, "Modern" is selected by default. "Classic" should be 
selected by default.

2) Navigator\Internet Search. I am using the netscape search (default), but 
when I open this panel, it displays "Search using: AOL Search" (which happens 
to be the first thing in the list). It should display "Search using: Netscape 
Search" which is the current setting.

I'm not exactly sure which other select-lists do this, but I think there are at 
least several others with the same behavior.

Using build 2000083111 on Windows 98 SE. Not sure if this happens on other 
platforms (I will check if it does on my linux machine and post additional 
comments then.)
(Reporter)

Updated

17 years ago
OS: other → Windows 98
Hardware: Other → PC
i see (1), so confirming... iirc, this also happens on mac and linux.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: correctness
Hardware: PC → All
(Reporter)

Comment 2

17 years ago
I've checked and this also happens on linux build 2000090108. (I assume it 
happens for all platforms.)
OS: Windows 98 → All

Comment 3

17 years ago
nav triage team:
is this still a bug, marking works for me (in Windows) for both themes and
search with build 2000092604.  Also works for Verah with 1 day older build.
M Future
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
vrfy. if this crops up again, rather than reopening this bug, could you pls file
a seperate bug for each pref panel for which there are uninitialized values? the
reason for that is that there a different owners for each of the panels (in
fact, there might already be bugs for such problems, but i cannot find 'em after
a couple of queries, alas.)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
bug 57532 filed-- reopen of case #1, as requested. Windows build 2000101908
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.