Closed Bug 510475 Opened 13 years ago Closed 8 years ago

Nicer defaults for which columns are shown in message list for RSS/Newsgroups (when upgrading to TB3)

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.12) Gecko/2009070611 Firefox/3.0.12 (.NET CLR 3.5.30729)
Build Identifier: TB 3.0 beta 3

Nicer defaults for which columns are shown in message list for RSS/Newsgroups (when upgrading to TB3)

Follow-up from bug 498209:
(In reply to comment #53)
> (In reply to comment #52)
> > 2) It's not very nice to make everyone manually hide/show the desired columns
> > for all of our RSS feeds, one at a time.
> 
> I agree.  The solution for RSS and Newsgroups is less than ideal.  Please open
> a new bug on that use case.  The suggestion of using the default email account
> is a good one; it is a definite rule that avoids us having to randomly choose
> one.  (Albeit not entirely obvious; I had to go to the account manager to see
> the "Set as Default" button to be sure we exposed such a thing in the UI.)
> 
> Although that options sounds good for the newsgroup case, perhaps for the RSS
> case we would just want a better set of (specialized) defaults?

I'm not sold on the idea of specialized defaults for either RSS or Newsgroup mailboxes.  It seems to me that TB2 users have already chosen the desired columns (even if it's a global setting) and I'm wondering if TB3 can figure out those columns from TB2's global setting and automatically apply it to all RSS & Newsgroup mailboxes when the user upgrades to TB3.

Reproducible: Always
On the other hand, for new TB3 users who aren't upgrading from TB2, perhaps a default set of columns makes more sense or perhaps could be based on the columns of the Inbox of the default email account, as mentioned.
I think how you implement this would become a lot less important if bug 504989 ("Restore Defaults in the column list chooser doesn't work") is going to allow us to change the visible columns globally on a per-account basis or such.  Maybe it would be nice to add a blurb to the release notes about that.
From a News reader perspective the pain of setting each news group individually is very high. The mix of Cols for News is not likely to be was selected for Mail, so a News default should be a different rule set. I believe the setter should look at an account for an existing array and repeat it for new subscriptions.  Only if this is a new server being setup in the Wizard would the factory default be applied.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
is there a proposal for the default set of columns in the RSS / News case?

I'm not sure if it is a separate bug for not overriding current column choices but it likely needs some tests and investigation outside of this.
With News there are Cols I always add so I can get more info from collapsed threads.  Cols include Total and Size. Other Cols I keep are Read, Flag, and Attachment. 

The Junk Col in Tb2 persists because of its thread pane design, yet it is not needed.  If the work to get some form of News Junk Filtering works out, then this Col should be a candidate for a news template.
This bug doesn't seem relevant anymore (certainly not if specifically concerned with Tb2->Tb3).  Column selection is quite easy to customize now, en masse, using the columnpickers Apply Columns To option, and state is persisted in the folder's database across updates.  Given this, specific column defaults for different account types seems unnecessary.  A UX person can confirm/reopen if not.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.