Search engine bugs which doesn't return the search result correctly

RESOLVED INCOMPLETE

Status

P4
minor
RESOLVED INCOMPLETE
9 years ago
3 years ago

People

(Reporter: genuinem22-bugger, Assigned: davedash)

Tracking

unspecified
x86
Windows XP

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

The search engine at AMO appears to be really buggy.

Manage Collection | Add to Collection searchbox:
Adblock => never return any result
Greasemonkey => sometimes no result is returned
hide menubar => displays 2 hide menubar extensions when in fact only 1 exists

Searchbar for add-ons and collections

Sometimes the result doesn't return if the capitalization is incorrect.
Search "wordawordb" doesn't return "WordAWordB". Tag search sometimes appears to be affected too.

I don't know all those problems have something to do with the same bug in your search engine.

That's really bugging me. It has happened more often than occasional so there should be something wrong on the server side or the search script. I have to resort to Google when AMO search appears to return wrong search results.

Reproducible: Sometimes
(Reporter)

Comment 1

9 years ago
https://addons.mozilla.org/en-US/firefox/tag/abe

It returns nothing the first time I visit.
I visits it later again and it returns NoScript correctly.
This kind of bugs keep happening. Does anyone experience similar problems like the above?
[1] Search is being re-written from scratch, over in bug 504699 and its dependencies.

[2] The AdBlock issue you mention is, I think, bug 510542, which will be fixed when we push on the 27th (tentative date).

[3] The URL you give in comment 1 works for me, but I don't doubt you; might have something to do with indexing or caching.

[4] I can confirm the "hide menubar" collection-creation autocompletion showing duplicate results.  I've filed bug 510727 for that.

Lastly, thanks for your help testing!  https://preview.addons.mozilla.org is our staging server, so you're encouraged to keep testing there and filing issues (fixes will show up there within 15 minutes).

Updated

9 years ago
Component: Public Pages → Search
QA Contact: web-ui → search
I think this is working now...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

9 years ago
I'm afraid not. The search is still broken and is not as reliable as Google.

1. Searching "xul" returns nothing when adding addons to a collection
Collector page
Add a new addon
Search for "xul"
Expected: returns the addon "XUL/Migemo" and "XUL Profiler"
Actual: returns nothing

2. Search for "tags everywhere" and "title save". Search result doesn't return the addons with the same name.

Please take a deep look into it and see which part goes wrong.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Wac,

Please provide URLs of the result pages they can assist me in tracing your issue.
-> davedash for confirmation or closing
Assignee: nobody → dd
Severity: major → minor
Priority: -- → P4
Target Milestone: --- → 5.5
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INCOMPLETE
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.