Closed Bug 510969 Opened 13 years ago Closed 12 years ago

clean up star-triggered "edit bookmark" dialog

Categories

(Firefox for Android Graveyard :: Bookmarks, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 514217

People

(Reporter: Gavin, Unassigned)

References

Details

Attachments

(2 obsolete files)

We currently re-use the same dialog for bookmark editing from the bookmark management UI and bookmark editing from the star popup. We should:

- remove "delete" and "move" from bookmark popup only (not from edit mode,
though that will need to be reworked a bit too)
- move buttons to the bottom (also not in edit mode)
Blocks: 477628
tracking-fennec: --- → ?
Attached patch patch (obsolete) — Splinter Review
I'm doing that for now but i'll probably explode the binding for some work on bug 514217 :)
Attached patch Patch (obsolete) — Splinter Review
forgot the wince css change
Attachment #399065 - Attachment is obsolete: true
hmmm, why the edit button in tthe bookmark list doesn't opened all the field to edit? Is it a design decision?
(In reply to comment #3)
> hmmm, why the edit button in tthe bookmark list doesn't opened all the field to
> edit? Is it a design decision?

What do you mean? I see 3 editboxes (title, url and tags) when I press the edit button in the bookmark list
(In reply to comment #4)
> (In reply to comment #3)
> > hmmm, why the edit button in tthe bookmark list doesn't opened all the field to
> > edit? Is it a design decision?
> 
> What do you mean? I see 3 editboxes (title, url and tags) when I press the edit
> button in the bookmark list

I spoke about the bookmarks UI reachable through the 'See all bookmarks' button in the awesomebar results
Comment on attachment 399066 [details] [diff] [review]
Patch

This patch is made obsolete by the work i'm doing on bug 514217
Attachment #399066 - Attachment is obsolete: true
Fixed by bug 514217
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514217
v dupe.
Status: RESOLVED → VERIFIED
Component: General → Bookmarks
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.