If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dismissing menu popup in editbookmark overlay causes chrome UI to flicker

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: xtc4uall, Assigned: Neil Deakin)

Tracking

({polish, regression})

1.9.2 Branch
x86
Windows XP
polish, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-interactive])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
STR:
1) add a bookmark using star button
2) click again on star button to get the bookmark editing menu
3) right-click either in the name or the tag field
4) dismiss the context menu popup with a left-click

=> notice the flicker on title and menu bar of Fx chrome UI

instead of 4)/5) you can also click successively on the folder dropdown field expanding and collapsing it.

if you use ESC key for dismissing, there's no flicker, so i presume some mouse event firing causes this bug.

there's no error console output.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20090817 Minefield/3.7a1pre ID:20090817050221

range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=860a9acc39b1&tochange=69c6dbdfd179
Flags: blocking-firefox3.6?
bug 404766, j'accuse!

Looks like a focus issue. Enn, we can haz fix?
Flags: wanted-firefox3.6+
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6-
Keywords: polish
Whiteboard: [polish-interactive]
(Reporter)

Updated

8 years ago
Blocks: 404766
Component: Bookmarks & History → XUL
Flags: wanted-firefox3.6+
Flags: blocking-firefox3.6-
Product: Firefox → Core
QA Contact: bookmarks → xptoolkit.widgets
Version: Trunk → 1.9.2 Branch
(Assignee)

Comment 2

7 years ago
Created attachment 490189 [details] [diff] [review]
Don't activate window when it is a panel
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Comment 3

7 years ago
Created attachment 490192 [details] [diff] [review]
Right patch
Attachment #490189 - Attachment is obsolete: true
(Assignee)

Comment 4

7 years ago
The flickering on pressing the folder dropdown looks like a different bug, unrelated to window focus.
(Assignee)

Updated

7 years ago
Attachment #490192 - Flags: review?(jmathies)

Comment 5

7 years ago
Comment on attachment 490192 [details] [diff] [review]
Right patch

looks good, I reproduced the flicker and with this patch, it's not present.
Attachment #490192 - Flags: review?(jmathies) → review+
(Assignee)

Updated

7 years ago
Attachment #490192 - Flags: approval2.0?

Updated

7 years ago
Attachment #490192 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 6

7 years ago
http://hg.mozilla.org/mozilla-central/rev/4d4cbab267d9
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

6 years ago
Depends on: 656865
Depends on: 746775
You need to log in before you can comment on or make changes to this bug.