If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Messages sent via forms on mozillaservice.org are not displayed on pages with the right charset

VERIFIED FIXED

Status

Websites Graveyard
mozillaservice.org
--
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: pascalc, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
1/ Go to http://mozillaservice.stage.mozilla.com/tell_us/your_stories
2/ Fill in the form with non-English letters like é¿áùsø...
3/ Display the recorded page like:
http://mozillaservice.stage.mozilla.com/activity/story/65
http://mozillaservice.stage.mozilla.com/activity/story/70

Actual results: non-English letters are displayed incorrectly
Expected results: letters displayed correctly with the right encoding

Comment 1

8 years ago
On the plus side... It looks like the data in the db is probably fine. I believe this is a html encoding issue, so fixing it will fix production stories.

Comment 2

8 years ago
Fixed. r49417. Added 'utf-8' to the htmlentities method call. It was encoding the characters as if they were ISO-8859-1.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
I think this is verified FIXED on http://mozillaservice.stage.mozilla.com/activity/story/71; not sure what you mean by "messages", though, Pascal?  Could you verify?  Thanks!
(Reporter)

Comment 4

8 years ago
Yes, this is fixed, thanks
Thx; verified.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: mozillaservice.org → mozillaservice.org
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.