Collection of email addresses is case sensitive

RESOLVED DUPLICATE of bug 129393

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 129393
9 years ago
9 years ago

People

(Reporter: Pouya K, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.2) Gecko/20090810 Gentoo Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.1) Gecko/20090818 Lightning/1.0pre Thunderbird/3.0b3

Option to "Automatically add outgoing e-mail addresses" to an address book (mail.collect_email_address_outgoing), results in duplicates when email address is only different in case. This is particularly problematic when ldap server and "From" line disagree. 

Reproducible: Always

Steps to Reproduce:
1. Turn on option to Automatically add outgoing e-mail addresses to some address book
2. Send email to an email address (e.g. a@example.com)
3. Send email to an email address that only differs in terms of case (e.g. A@example.com)

Actual Results:  
Both a@example.com and A@example.com appear in collected address book.

Expected Results:  
Only the first should.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129393
To the best of my knowledge the case sensitivity bug still exists in the main code.  To get it fixed please go to bug 129393 and click the vote button to raise its level of importance.
You need to log in before you can comment on or make changes to this bug.