File extension not used on FTP downloads

VERIFIED DUPLICATE of bug 48889

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 48889
18 years ago
13 years ago

People

(Reporter: Moses Lei, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Try to download a Red Hat package on this page: 
http://www.freeciv.org/download.phtml

You will get the dialog for "This file has mime type application/octet-stream 
and cannot be viewed by Mozilla." Now go to "Save to disk" and click OK. You 
will see that Mozilla has chosen the extension of .exe for you, and doesn't 
take the extension from the real filename which is (e.g.) "freeciv-1.11.4-
1.i586.rpm" . So when I save it, I have a file named "freeciv-1.11.4-
1.i586.exe" which is not what I want.

The behavior should be that Mozilla should try to use the exact filename 
specified by the URL.

Oddly enough, another weird behavior (this might be a different bug, but I'm 
not sure...). If you click to download the gzipped source code, the same dialog 
will come up, but the name Mozilla will want to give it is "test.exe". What's 
up with this?

Running 2000090110 Windows.

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 48889 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.