[autoconfig] Setting invalid hostname then correcting can lead to -1 being displayed in insecure notices

RESOLVED FIXED in Thunderbird 3.0b4

Status

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Trunk
Thunderbird 3.0b4
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 395803 [details] [diff] [review]
The fix

STR:

1) With a configuration that isn't in the database (e.g. my standard8.plus.com one), go through the normal procedure and it fails (expected).
2) Enter invalid hostnames for both servers (e.g. use .com instead of .net which is something I frequently get wrong).
3) Re-test account config - which then fails.
4) Enter correct hostnames for both servers - this succeeds
5) Select finish and go to the insecure notice.

Actual Result:

The insecure notice has server details such as "-1:143"

Expected Result:

The hostname and port.



The best I've worked this out is that we're storing the errors in incomingEx and outgoingEx within guessConfig. I think we hit incomingError at step 3 which sets incomingEx.

Then we enter the correct details, and we get into incomingSuccess - which calls checkDone(). However incomingEx is still set, so the failure routine gets called rather than the success one.

So I think the fix is to null out incomingEx/outgoingEx in their respective success functions and assume that these aren't called in failure cases.
Attachment #395803 - Flags: superreview?(bienvenu)
Attachment #395803 - Flags: review?(philringnalda)
(Assignee)

Comment 1

9 years ago
Oh btw I've seen this before and found it whilst I was re-investigating the blocker bug 490139.
Flags: wanted-thunderbird3+

Comment 2

9 years ago
Comment on attachment 395803 [details] [diff] [review]
The fix

this looks reasonable, though I haven't tried running with the patch.
Attachment #395803 - Flags: superreview?(bienvenu) → superreview+
Attachment #395803 - Flags: review?(philringnalda) → review+
(Assignee)

Comment 3

9 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/2093c7c10eea
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.